CVE-2026-77521: MaxKB: Prompt-injectable agent can lead to command execution
Vulnerability summary
CVE-2026-77521 is a critical (CVSS 10.0) vulnerability in 1panel-dev maxkb. EPSS estimates a 1.05% chance of exploitation in the next 30 days, higher than 64.2% of scored vulnerabilities.
Severe, CVSS 10 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 1% (FIRST, 03-11-2026)
Source freshness unavailable
How is this decided?Timeline
- 21-09-2026PublishedVulnerability first disclosed.
- 22-09-2026Last modifiedVulnerability information updated.
Description
MaxKB is an open-source AI assistant for enterprise. Prior to version 2.10.5-lts, assistants with a tool, MCP tool, skill, or sub-application use SandboxShellBackend, which exposes an execute shell tool without excluding it and omits execute from interrupt_on, so human approval is not required. Untrusted chat or ingested content can therefore cause command execution; source deployments with MAXKB_SANDBOX disabled run commands directly as the application user, while the official root container's string-based gosu wrapper allowed shell metacharacters to execute outside the intended sandbox. This issue is fixed in version 2.10.5-lts.
CVSS metrics
2 scores · 2 sources · 1 version- NVDNIST10.0CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS trend
Probability
1.05%
Chance of exploitation in the next 30 days
Percentile
64%
Versus all other CVEs
30-day change
No change 0.00 pp
From 1.05% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root cause- CWE-78Improper Neutralization of Special Elements used in an OS CommandThe product constructs all or part of an OS command using externally-influenced input from an upstream component, but it does not neutralize or incorrectly neutralizes special elements that could modify the intended OS command before it is sent to a downstream component.
- CWE-250Execution with Unnecessary PrivilegesThe product performs an operation at a privilege level that is higher than the minimum level required, which creates new weaknesses or amplifies the consequences of other weaknesses.
- CWE-749Exposed Dangerous Method or FunctionThe product provides an Applications Programming Interface (API) or similar interface for interaction with external actors, but the interface includes a dangerous method or function that is not properly restricted.
Affected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
1panel-dev1 product
- maxkb< 2.10.5-lts
1 vendor · 1 product
References
3 links- github.com/1Panel-dev/MaxKB/security/advisories/GHSA-f36j-f34j-h3rxX Refsource CONFIRM
- github.com/1Panel-dev/MaxKB/releases/tag/v2.10.5-ltsX Refsource MISC