8.8

CVE-2026-84317: Nginx UI: MCP nginx_config_add skips config directive validation → authenticated nginx directive injection (RCE on the official image)

Deferred
AliasesGHSA-76pm-mq2q-9gcrGO-2026-6779
Published 12-10-2026Last modified 13-10-2026

Vulnerability summary

CVE-2026-84317 is a high (CVSS 8.8) Improper Input Validation vulnerability in 0xjacky nginx-ui. EPSS estimates a 0.48% chance of exploitation in the next 30 days, higher than 41.2% of scored vulnerabilities.

Priority
Routine

Not severe (CVSS 8.8, network access); no exploitation reported by the 5 checked sources

Source freshness unavailable

How is this decided?
CVSS score
8.8/10
010
High · v3.1 (NVD)
EPSS score
0.48%
0%100%
Low · Change unavailable
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Timeline

  1. 12-10-2026
    PublishedVulnerability first disclosed.
  2. 13-10-2026
    Last modifiedVulnerability information updated.

Description

Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, internal/config/validation.go (ValidateConfigFile) is a security control that blocks dangerous nginx directives — js_*, perl_*, load_module of the njs/perl modules, and user root. It is enforced on three of the four config-write paths: api/config/add.go, api/config/modify.go, and mcp/config/config_modify.go. The fourth path — the MCP tool nginx_config_add (mcp/config/config_add.go) — does NOT call it: it writes the caller-supplied content straight to disk and reloads nginx. An authenticated MCP caller (or an MCP agent induced via prompt injection) can therefore inject exactly the directives the control is meant to block, leading to nginx code execution on deployments where the njs/perl module is available (e.g. the official Docker image). This issue is fixed in version 2.4.1.

CVSS metrics

3 scores · 3 sources · 1 version

EPSS trend

Probability

0.48%

Chance of exploitation in the next 30 days

Percentile

41%

Versus all other CVEs

30-day change

Change unavailable

Change unavailable

13-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, low-privilege account, no user interaction (CVSS vector). Other conditions: not stated in public data.

0xjacky1 product
Github.com/0xJacky1 product
  • Nginx-UI< 1.9.10-0.20260703131214-23d1934099b0

2 vendors · 2 products

References

5 links