5.9

CVE-2026-84890: undici vulnerable to Denial of Service via unbounded decompression of compressed responses

Analyzed
AliasesUBUNTU-CVE-2026-84890DEBIAN-CVE-2026-84890CGA-2c69-2ccw-6g4p
Published 04-09-2026Last modified 04-09-2026

Vulnerability summary

CVE-2026-84890 is a medium (CVSS 5.9) vulnerability in nodejs undici. EPSS estimates a 0.41% chance of exploitation in the next 30 days, higher than 35.5% of scored vulnerabilities.

Priority
Routine

Not severe (CVSS 5.9, network access); no exploitation reported by the 5 checked sources

Source freshness unavailable

How is this decided?
CVSS score
5.9/10
010
Medium · v3.1 (CVE.org)
EPSS score
0.41%
0%100%
Low · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 4 · Related 1

Timeline

  1. 04-09-2026
    PublishedVulnerability first disclosed.
  2. 04-09-2026
    Last modifiedVulnerability information updated.

Description

undici's decompress interceptor decompresses response bodies according to the untrusted Content-Encoding header. While the number of content-encoding layers is capped, the total decompressed output size is unbounded and there is no configuration option to limit it. A malicious or faulty upstream can therefore return a small compressed payload, a compression bomb, that expands to hundreds of megabytes or more in client memory, an asymmetric resource consumption that can exhaust memory and crash the process. This affects undici versions from 7.15.0 up to 7.29.1 and from 8.0.0 up to 8.10.2. Users should upgrade to undici 7.29.1 or 8.10.2.

CVSS metrics

7 scores · 7 sources · 1 version

EPSS trend

Probability

0.41%

Chance of exploitation in the next 30 days

Percentile

36%

Versus all other CVEs

30-day change

No change 0.00 pp

From 0.41% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Chainguard14 products
  • code-server< 4.139.1-r2
  • commercial-gitlab-rails-ee-19.1< 19.1.7-r3
  • commercial-gitlab-rails-ee-19.2< 19.2.7-r1
  • commercial-gitlab-rails-ee-19.3< 19.3.3-r1
  • commercial-gitlab-rails-ee-19.4< 19.4.1-r1
Wolfi4 products
  • code-server< 4.139.1-r2
  • lernaAll versions (No fix recorded) | < 10.0.1-r11
  • node-gyp< 13.0.2-r1
  • prism< 5.16.0-r14
Debian1 product
  • node-undiciAll versions (No fix recorded) | < 8.10.2+dfsg+~cs3.2.2-1
Nodejs1 product
  • undici≥ 7.15.0, < 7.29.1 | ≥ 8.0.0, < 8.10.2
Npm1 product
  • undici≥ 7.15.0, < 7.29.1 | ≥ 8.0.0, < 8.10.2
Ubuntu1 product
  • node-undiciAll versions (No fix recorded)
Undici1 product
  • undici≥ 7.15.0, < 7.29.1 | ≥ 8.0.0, < 8.10.2

7 vendors · 23 products

References

12 links
Show all 12 references