9.1

CVE-2026-84961: undici vulnerable to TLS certificate validation bypass via dropped connect options in BalancedPool

Analyzed
AliasesUBUNTU-CVE-2026-84961DEBIAN-CVE-2026-84961CGA-5p6x-554c-2756
Published 04-09-2026Last modified 04-09-2026

Vulnerability summary

CVE-2026-84961 is a critical (CVSS 9.1) Improper Certificate Validation vulnerability in nodejs undici. EPSS estimates a 0.18% chance of exploitation in the next 30 days, higher than 7.4% of scored vulnerabilities.

Priority
Prioritisesevere

Severe, CVSS 7.4 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 0% (FIRST, 03-11-2026)

Source freshness unavailable

How is this decided?
CVSS score
9.1/10
010
Critical · v3.1 (NVD)
EPSS score
0.18%
0%100%
Low · +0.03 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 8 · Related 2

Timeline

  1. 04-09-2026
    PublishedVulnerability first disclosed.
  2. 04-09-2026
    Last modifiedVulnerability information updated.

Description

undici's BalancedPool constructor passes its entire options object through an internal deep-clone that serializes and reparses the value as JSON. Because JSON cannot represent functions, any function-valued TLS option, such as a caller-supplied checkServerIdentity callback or a custom connector inside the connect option, is silently discarded before it reaches the TLS layer. As a result a peer whose certificate the application's custom checkServerIdentity was written to reject, but which still passes Node's default hostname and chain checks, is accepted when reached through BalancedPool. The Client, Pool, and Agent dispatchers are not affected because they extract the connect and tls options before cloning. This affects undici versions from 7.24.1 up to 7.29.1 and from 8.0.0 up to 8.10.2, and only when the application supplies a function-valued connect or tls option to BalancedPool. Users should upgrade to undici 7.29.1 or 8.10.2.

CVSS metrics

7 scores · 7 sources · 1 version

EPSS trend

Probability

0.18%

Chance of exploitation in the next 30 days

Percentile

7%

Versus all other CVEs

30-day change

Increase +0.03 pp

From 0.15% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Chainguard14 products
  • code-server< 4.139.1-r2
  • commercial-gitlab-rails-ee-19.1< 19.1.7-r3
  • commercial-gitlab-rails-ee-19.2< 19.2.7-r1
  • commercial-gitlab-rails-ee-19.3< 19.3.3-r1
  • commercial-gitlab-rails-ee-19.4< 19.4.1-r1
Wolfi4 products
  • code-server< 4.139.1-r2
  • lernaAll versions (No fix recorded) | < 10.0.1-r11
  • node-gyp< 13.0.2-r1
  • prism< 5.16.0-r14
Debian1 product
  • node-undiciAll versions (No fix recorded) | < 8.10.2+dfsg+~cs3.2.2-1
Nodejs1 product
  • undici≥ 7.24.1, < 7.29.1 | ≥ 8.0.0, < 8.10.2
Npm1 product
  • undici≥ 7.24.1, < 7.29.1 | ≥ 8.0.0, < 8.10.2
Ubuntu1 product
  • node-undiciAll versions (No fix recorded)
Undici1 product
  • undici≥ 7.24.1, < 7.29.1 | ≥ 8.0.0, < 8.10.2

7 vendors · 23 products

References

12 links
Show all 12 references