5.9

CVE-2026-85024: undici vulnerable to Denial of Service via unhandled error in WebSocket permessage-deflate decompression

Analyzed
AliasesUBUNTU-CVE-2026-85024DEBIAN-CVE-2026-85024CGA-282f-qxh9-v4cp
Published 04-09-2026Last modified 04-09-2026

Vulnerability summary

CVE-2026-85024 is a medium (CVSS 5.9) Uncaught Exception vulnerability in nodejs undici. EPSS estimates a 0.41% chance of exploitation in the next 30 days, higher than 35.5% of scored vulnerabilities.

Priority
Routine

Not severe (CVSS 5.9, network access); no exploitation reported by the 5 checked sources

Source freshness unavailable

How is this decided?
CVSS score
5.9/10
010
Medium · v3.1 (CVE.org)
EPSS score
0.41%
0%100%
Low · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 4 · Related 1

Timeline

  1. 04-09-2026
    PublishedVulnerability first disclosed.
  2. 04-09-2026
    Last modifiedVulnerability information updated.

Description

undici bundles a WebSocket client whose permessage-deflate size-limit cleanup removes all listeners from the internal zlib inflate stream, including its error listener, while that stream can still emit. When a remote peer sends a compressed payload that crosses the built-in 128 MiB decompressed-payload limit and then contains a malformed DEFLATE byte, the inflate stream emits a data error with no listener attached, which Node.js treats as a fatal unhandled error and terminates the entire process. Exploitation is remote and unauthenticated, requires no application mistake, and is asymmetric, since roughly 130 KB on the wire expands past the limit and crashes the process, and reconnecting can repeat the crash. This affects undici versions from 6.25.0 up to 6.28.1, from 7.28.0 up to 7.29.1, and from 8.1.0 up to 8.10.2. Users should upgrade to undici 6.28.1, 7.29.1, or 8.10.2.

CVSS metrics

7 scores · 7 sources · 1 version

EPSS trend

Probability

0.41%

Chance of exploitation in the next 30 days

Percentile

36%

Versus all other CVEs

30-day change

No change 0.00 pp

From 0.41% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Chainguard13 products
  • actions-runner< 2.337.0-r2
  • code-server< 4.139.1-r2
  • commercial-gitlab-rails-ee-19.4< 19.4.1-r1
  • commercial-gitlab-rails-ee-fips-19.4< 19.4.1-r1
  • homepage< 2.4.0-r1
Wolfi6 products
  • code-server< 4.139.1-r2
  • lernaAll versions (No fix recorded) | < 10.0.1-r11
  • prism< 5.16.0-r14
  • pulumi-language-nodejs< 3.265.0-r3
  • renovate< 44.131.0-r1 | < 44.133.0-r0 | < 44.118.2-r0 | < 44.119.1-r0
Debian1 product
  • node-undiciAll versions (No fix recorded) | < 8.10.2+dfsg+~cs3.2.2-1
Nodejs1 product
  • undici≥ 6.25.0, < 6.28.1 | ≥ 7.28.0, < 7.29.1 | ≥ 8.1.0, < 8.10.2
Npm1 product
  • undici≥ 6.25.0, < 6.28.1 | ≥ 7.28.0, < 7.29.1 | ≥ 8.1.0, < 8.10.2
Ubuntu1 product
  • node-undiciAll versions (No fix recorded)
Undici1 product
  • undici≥ 6.25.0, < 6.28.1 | ≥ 7.28.0, < 7.29.1 | ≥ 8.1.0, < 8.10.2

7 vendors · 24 products

References

14 links
Show all 14 references