7.5

CVE-2026-87776: compression vulnerable to Denial of Service via memory leak on premature response close

Awaiting analysis
AliasesUBUNTU-CVE-2026-87776DEBIAN-CVE-2026-87776CGA-239q-qmpm-f6vj
Published 11-09-2026Last modified 11-09-2026

Vulnerability summary

CVE-2026-87776 is a high (CVSS 7.5) vulnerability in compression. EPSS estimates a 0.48% chance of exploitation in the next 30 days, higher than 41.2% of scored vulnerabilities.

Priority
Prioritisesevere

Severe, CVSS 7.5 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 0% (FIRST, 03-11-2026)

Source freshness unavailable

How is this decided?
CVSS score
7.5/10
010
High · v3.1 (CVE.org)
EPSS score
0.48%
0%100%
Low · -0.13 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Timeline

  1. 11-09-2026
    PublishedVulnerability first disclosed.
  2. 11-09-2026
    Last modifiedVulnerability information updated.

Description

compression is a Node.js and Express compression middleware. In versions before 1.8.2, when a client aborts the connection while a compressed response is still being sent, the zlib stream created to compress that response is never destroyed, so each aborted compressed response leaks its native zlib memory. A remote unauthenticated attacker can repeatedly open requests and disconnect early, exhausting the available memory and crashing the server. All applications using compression are affected. The issue is fixed in compression 1.8.2, and users should upgrade to 1.8.2 or later.

CVSS metrics

7 scores · 7 sources · 1 version

EPSS trend

Probability

0.48%

Chance of exploitation in the next 30 days

Percentile

41%

Versus all other CVEs

30-day change

Decrease -0.13 pp

From 0.61% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Chainguard25 products
  • arangodb-3.12< 3.12.12.1-r7
  • code-server< 4.140.0-r3
  • dotstatsuite-supercore< 3.1.0_git20261001-r4
  • eco-jessAll versions (No fix recorded) | < 2026.10.28.40754326399001-r0 | < 2026.10.28.40737702110001-r0
  • gitlab-rails-ce-18.10All versions (No fix recorded)
Wolfi6 products
  • code-server< 4.140.0-r3
  • jupyter-base-notebook< 7.6.3-r2
  • serve< 14.2.6-r8
  • sqlpadAll versions (No fix recorded)
  • thingsboard-tb-web-ui< 4.3.1.5-r7
Compression1 product
Debian1 product
  • node-compressionAll versions (No fix recorded) | < 1.8.2+~1.8.1-1
Npm1 product
  • compression< 1.8.2
Ubuntu1 product
  • node-compressionAll versions (No fix recorded)

6 vendors · 35 products

References

10 links