9.1

CVE-2026-90711: proxy-addr vulnerable to IP spoofing via IPv4-mapped IPv6 trust subnet

Awaiting analysis
AliasesUBUNTU-CVE-2026-90711DEBIAN-CVE-2026-90711CGA-2922-5hxc-r8x7
Published 15-09-2026Last modified 15-09-2026

Vulnerability summary

CVE-2026-90711 is a critical (CVSS 9.1) Authentication Bypass by Spoofing vulnerability in proxy-addr. EPSS estimates a 0.26% chance of exploitation in the next 30 days, higher than 17.7% of scored vulnerabilities.

Priority
Prioritisesevere

Severe, CVSS 9.1 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 0% (FIRST, 03-11-2026)

Source freshness unavailable

How is this decided?
CVSS score
9.1/10
010
Critical · v3.1 (CVE.org)
EPSS score
0.26%
0%100%
Low · -0.07 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Timeline

  1. 15-09-2026
    PublishedVulnerability first disclosed.
  2. 15-09-2026
    Last modifiedVulnerability information updated.

Description

proxy-addr is a Node.js module that determines a request's client address behind trusted reverse proxies, and it backs Express req.ip and req.ips. In versions 1.1.0 through 2.0.7, a trust subnet written in IPv4-mapped IPv6 notation with an IPv4-sized prefix, such as ::ffff:10.0.0.0/8 instead of the correct ::ffff:10.0.0.0/104, is accepted without error but trusts every IPv4 address on the internet rather than the block it names. Because the socket peer then becomes trusted at hop 0, any unauthenticated client can supply an arbitrary X-Forwarded-For header and control the address the application reads, which defeats IP-based access control, rate limiting, geolocation, and audit logging. This is a fail-open regression introduced in version 1.1.0. The issue is fixed in proxy-addr 2.0.8, and users should upgrade to 2.0.8 or later. As a workaround, ensure any IPv4-mapped IPv6 trust subnet uses a prefix length of at least 97, or express the range in plain IPv4 notation.

CVSS metrics

7 scores · 7 sources · 1 version

EPSS trend

Probability

0.26%

Chance of exploitation in the next 30 days

Percentile

18%

Versus all other CVEs

30-day change

Decrease -0.07 pp

From 0.33% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Chainguard59 products
  • arangodb-3.12< 3.12.12.1-r4
  • azurite< 3.37.0-r5
  • commercial-gitlab-rails-ee-19.1< 19.1.7-r3
  • commercial-gitlab-rails-ee-19.2< 19.2.7-r1
  • commercial-gitlab-rails-ee-19.3< 19.3.3-r1
Wolfi8 products
  • jupyter-base-notebook< 7.6.3-r2
  • kubeflow-centraldashboard< 2.0.0-r6
  • kubeflow-pipelines-frontend< 2.17.2-r8
  • langfuse-3-worker< 3.225.11-r6
  • sqlpad< 7.5.7-r47
Debian1 product
  • node-proxy-addrAll versions (No fix recorded) | < 2.0.8+~cs2.3.7-1
Npm1 product
  • proxy-addr≥ 1.1.0, < 2.0.8
Proxy-addr1 product
Ubuntu1 product
  • node-proxy-addrAll versions (No fix recorded)

6 vendors · 71 products

References

10 links