CVE-2026-9678: undici vulnerable to cross-user information disclosure via shared cache whitespace bypass
Vulnerability summary
CVE-2026-9678 is a medium (CVSS 5.9) vulnerability in nodejs undici. EPSS estimates a 0.39% chance of exploitation in the next 30 days, higher than 33% of scored vulnerabilities.
Not severe (CVSS 5.9, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 13 · Related 5Timeline
- 17-06-2026PublishedVulnerability first disclosed.
- 17-06-2026Last modifiedVulnerability information updated.
Description
Impact: Undici's cache interceptor incorrectly classifies some responses as cacheable when the upstream Cache-Control header uses whitespace-padded qualified private or no-cache field names such as private=" authorization" or no-cache="\tauthorization". The parser preserves the surrounding whitespace, so later comparisons against the literal authorization field name fail and the response is stored. In shared-cache mode, this allows a response containing one user's authenticated data to be served from cache to a subsequent caller, including an unauthenticated caller, when both requests resolve to the same cache key. Affected applications are those that explicitly enable the cache interceptor (interceptors.cache()) in shared mode, forward Authorization headers upstream, and receive cacheable responses with non-canonical qualified private or no-cache directives. Patches: Upgrade to undici v7.28.0 or v8.5.0. Workarounds: If upgrade is not immediately possible, disable shared-cache mode for traffic that includes Authorization headers, avoid caching responses to authenticated requests, or add Vary: Authorization upstream.
CVSS metrics
7 scores · 7 sources · 1 version- OSV · UbuntuEcosystem advisory · calculated5.9MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- OSV · DebianEcosystem advisory · calculated5.9MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- OSV · WolfiEcosystem advisory · calculated5.9MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- OSV · NpmEcosystem advisory · calculated5.9MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- OSV · ChainguardEcosystem advisory · calculated5.9MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- NVDNIST5.9MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS trend
Probability
0.39%
Chance of exploitation in the next 30 days
Percentile
33%
Versus all other CVEs
30-day change
Decrease -0.03 pp
From 0.42% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Chainguard29 products
- code-server< 4.125.0-r2
- commercial-gitlab-rails-ee-19.1< 19.1.7-r3
- commercial-gitlab-rails-ee-19.2< 19.2.7-r1
- commercial-gitlab-rails-ee-19.3< 19.3.3-r1
- commercial-gitlab-rails-ee-fips-19.1All versions (No fix recorded) | < 19.1.9-r0
Wolfi7 products
- code-server< 4.125.0-r2
- langfuse-3< 3.194.0-r0
- langfuse-3-compat< 3.225.7-r6
- langfuse-3-worker< 3.194.0-r0
- renovate< 43.247.0-r0
Debian1 product
- node-undiciAll versions (No fix recorded) | < 8.5.0+dfsg+~cs3.2.0-1
Nodejs1 product
- undici≥ 7.0.0, < 7.28.0 | ≥ 8.0.0, < 8.5.0
Npm1 product
- undici≥ 7.0.0, < 7.28.0 | ≥ 8.0.0, < 8.5.0
Ubuntu1 product
- node-undiciAll versions (No fix recorded)
Undici1 product
- undici≥ 7.0.0, < 7.28.0 | ≥ 8.0.0, < 8.5.0
7 vendors · 41 products
References
8 links- github.com/nodejs/undici/security/advisories/GHSA-pr7r-676h-xcf6REPORTAdvisoryWEBMitigationVendor Advisory
- github.com/nodejs/undiciPACKAGE