CVE-2026-9697: undici vulnerable to TLS certificate validation bypass via dropped requestTls in SOCKS5 ProxyAgent
Vulnerability summary
CVE-2026-9697 is a high (CVSS 7.4) Improper Certificate Validation vulnerability in nodejs undici. EPSS estimates a 0.46% chance of exploitation in the next 30 days, higher than 39.8% of scored vulnerabilities.
Severe, CVSS 7.4 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 0% (FIRST, 03-11-2026)
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 7 · Related 1Timeline
- 17-06-2026PublishedVulnerability first disclosed.
- 10-09-2026Last modifiedVulnerability information updated.
Description
Impact: undici's ProxyAgent silently drops the requestTls option when configured with a SOCKS5 proxy URI (socks5:// or socks://). The target HTTPS connection through the SOCKS5 tunnel falls back to Node's default trust store, ignoring user-configured ca, cert, key, rejectUnauthorized, and servername settings. Applications that pin to an internal or corporate CA via requestTls.ca will, when their proxy URI is SOCKS5, get the default Mozilla CA bundle as the trust anchor instead. Any cert signed by any publicly-trusted CA for the target hostname is accepted, breaking the intended pin and enabling MITM read and tamper of the HTTPS exchange. Affected applications are those that use undici's ProxyAgent (or Socks5ProxyAgent directly) with SOCKS5 AND rely on requestTls for TLS scope restriction. The bug was introduced in undici 7.23.0 when SOCKS5 support was added. Patches: Upgrade to undici v7.28.0 or v8.5.0. Workarounds: No workaround is available within the SOCKS5 path. If a SOCKS5 proxy with TLS scope restriction is required and an upgrade is not yet possible, route the traffic through an HTTP-proxy ProxyAgent instead, where requestTls is honored correctly.
CVSS metrics
7 scores · 7 sources · 1 version- OSV · UbuntuEcosystem advisory · calculated7.4HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- OSV · DebianEcosystem advisory · calculated7.4HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- OSV · WolfiEcosystem advisory · calculated7.4HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- OSV · NpmEcosystem advisory · calculated7.4HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- OSV · ChainguardEcosystem advisory · calculated7.4HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- NVDNIST7.4HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS trend
Probability
0.46%
Chance of exploitation in the next 30 days
Percentile
40%
Versus all other CVEs
30-day change
Decrease -0.09 pp
From 0.55% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Chainguard28 products
- code-server< 4.125.0-r2
- commercial-gitlab-rails-ee-19.1< 19.1.7-r3
- commercial-gitlab-rails-ee-19.2< 19.2.7-r1
- commercial-gitlab-rails-ee-19.3< 19.3.3-r1
- commercial-gitlab-rails-ee-fips-19.1All versions (No fix recorded) | < 19.1.9-r0
Wolfi7 products
- code-server< 4.125.0-r2
- langfuse-3< 3.194.0-r0
- langfuse-3-compat< 3.225.7-r6
- langfuse-3-worker< 3.194.0-r0
- renovate< 43.247.0-r0
Debian1 product
- node-undiciAll versions (No fix recorded) | < 8.5.0+dfsg+~cs3.2.0-1
Nodejs1 product
- undici≥ 7.23.0, < 7.28.0 | ≥ 8.0.0, < 8.5.0
Npm1 product
- undici≥ 7.23.0, < 7.28.0 | ≥ 8.0.0, < 8.5.0
Ubuntu1 product
- node-undiciAll versions (No fix recorded)
Undici1 product
- undici≥ 7.23.0, < 7.28.0 | ≥ 8.0.0, < 8.5.0
7 vendors · 40 products
References
31 links- github.com/nodejs/undici/security/advisories/GHSA-vmh5-mc38-953gREPORTAdvisoryWEBMitigationVendor Advisory
Show all 31 references
- github.com/nodejs/undiciPACKAGE