USN-5910-1: ruby-rack Ubuntu
Vulnerability summary
USN-5910-1 is a vulnerability in ruby-rack Ubuntu with no CVSS score yet.
No CVSS vector published; no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 3 · Downstream 0 · Related 3Timeline
- 02-03-2023PublishedVulnerability first disclosed.
- 29-06-2026Last modifiedVulnerability information updated.
Description
ruby-rack vulnerabilities It was discovered that Rack did not properly structure regular expressions in some of its parsing components, which could result in uncontrolled resource consumption if an application using Rack received specially crafted input. A remote attacker could possibly use this issue to cause a denial of service. (CVE-2022-44570, CVE-2022-44571) It was discovered that Rack did not properly structure regular expressions in its multipart parsing component, which could result in uncontrolled resource consumption if an application using Rack to parse multipart posts received specially crafted input. A remote attacker could possibly use this issue to cause a denial of service. This issue was only fixed in Ubuntu 20.04 ESM and Ubuntu 22.04 ESM. (CVE-2022-44572)
CVSS metrics
Risk metrics not yet published.
EPSS trend
No EPSS score has been published for this record yet.
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeNo weakness data has been published for this record.
Affected systems
Known conditions: not stated in public data.
Ubuntu1 product
- ruby-rack< 1.5.2-3+deb8u3ubuntu1~esm6 | < 1.6.4-3ubuntu0.2+esm4 | < 1.6.4-4ubuntu0.2+esm4 | < 2.0.7-2ubuntu0.1+esm3 | < 2.1.4-5ubuntu1+esm3
1 vendor · 1 product