USN-7015-2: python2.7 Ubuntu
Vulnerability summary
USN-7015-2 is a vulnerability in python2.7 Ubuntu with no CVSS score yet.
No CVSS vector published; no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 2 · Downstream 0 · Related 2Timeline
- 19-09-2024PublishedVulnerability first disclosed.
- 25-06-2026Last modifiedVulnerability information updated.
Description
python2.7, python3.5 vulnerabilities USN-7015-1 fixed several vulnerabilities in Python. This update provides one of the corresponding updates for python2.7 for Ubuntu 16.04 LTS, Ubuntu 18.04 LTS, Ubuntu 20.04 LTS, and Ubuntu 22.04 LTS, and a second for python3.5 for Ubuntu 16.04 LTS. Original advisory details: It was discovered that Python allowed excessive backtracking while parsing certain tarfile headers. A remote attacker could possibly use this issue to cause Python to consume resources, leading to a denial of service. This issue only affected python3.5 for Ubuntu 16.04 LTS (CVE-2024-6232) It was discovered that the Python http.cookies module incorrectly handled parsing cookies that contained backslashes for quoted characters. A remote attacker could possibly use this issue to cause Python to consume resources, leading to a denial of service. (CVE-2024-7592)
CVSS metrics
Risk metrics not yet published.
EPSS trend
No EPSS score has been published for this record yet.
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeNo weakness data has been published for this record.
Affected systems
Known conditions: not stated in public data.
Ubuntu2 products
- python2.7< 2.7.12-1ubuntu0~16.04.18+esm10 | < 2.7.17-1~18.04ubuntu1.13+esm5 | < 2.7.18-1~20.04.4+esm2 | < 2.7.18-13ubuntu1.2+esm2
- python3.5< 3.5.2-2ubuntu0~16.04.13+esm14
1 vendor · 2 products