Paul L Daniels Ripmime vulnerabilities
10 vulnerabilities
Known vulnerabilities in Paul L Daniels Ripmime, newest first, with CVSS severity, EPSS, KEV listings, ransomware use and the affected versions.
CVE-2003-1016clearswiftmailsweeper+2
EPSS score2.45%
Multiple content security gateway and antivirus products allow remote attackers to bypass content restrictions via MIME messages that use malformed quoting in MIME headers, parameters, and values, including (1) fields that should not be quoted, (2) duplicate quotes, or (3) missing leading or trailing quote characters, which may be interpreted differently by mail clients.CVE-2003-1015clearswiftmailsweeper+2EPSS score2.45%
Multiple content security gateway and antivirus products allow remote attackers to bypass content restrictions via MIME messages that use whitespace in an unusual fashion, which may be interpreted differently by mail clients.CVE-2004-2619paul_l_danielsripmimeEPSS score1.54%
ripMIME 1.3.2.3 and earlier allows remote attackers to bypass e-mail protection via a base64 MIME encoded attachment containing invalid characters that are not properly extracted.CVE-2004-2620paul_l_danielsripmimeEPSS score0.87%
The MIMEH_read_headers function in ripMIME 1.3.1.0 does not properly handle trailing "\r" and "\n" characters in headers, which leads to a buffer underflow.CVE-2004-0053clearswiftmailsweeper+2EPSS score2.38%
Multiple content security gateway and antivirus products allow remote attackers to bypass content restrictions via MIME messages that use fields that use RFC2047 encoding, which may be interpreted differently by mail clients.CVE-2004-0162clearswiftmailsweeper+2EPSS score2.38%
Multiple content security gateway and antivirus products allow remote attackers to bypass content restrictions via MIME encapsulation that uses RFC822 comment fields, which may be interpreted as other fields by mail clients.CVE-2004-0051clearswiftmailsweeper+2EPSS score2.38%
Multiple content security gateway and antivirus products allow remote attackers to bypass content restrictions via MIME messages that use non-standard but frequently supported Content-Transfer-Encoding values such as (1) uuencode, (2) mac-binhex40, and (3) yenc, which may be interpreted differently by mail clients.CVE-2004-0052clearswiftmailsweeper+2EPSS score2.38%
Multiple content security gateway and antivirus products allow remote attackers to bypass content restrictions via MIME messages that use non-standard separator characters, or use standard separators incorrectly, within MIME headers, fields, parameters, or values, which may be interpreted differently by mail clients.CVE-2004-0161clearswiftmailsweeper+2EPSS score2.38%
Multiple content security gateway and antivirus products allow remote attackers to bypass content restrictions via MIME messages that use RFC2231 encoding, which may be interpreted differently by mail clients.CVE-2002-0198paul_l_danielsinflex+1EPSS score5.33%
Buffer overflow in plDaniels ripMime 1.2.6 and earlier, as used in other programs such as xamime and inflex, allows remote attackers to execute arbitrary code via an attachment in a long filename.