6.1

CVE-2018-1000078: debian debian_linux

Modified
AliasesUBUNTU-CVE-2018-1000078DEBIAN-CVE-2018-1000078GHSA-87qx-g5wg-mwmj
Published 13-03-2018Last modified 05-08-2024

Vulnerability summary

CVE-2018-1000078 is a medium (CVSS 6.1) vulnerability in debian debian_linux. EPSS estimates a 2.75% chance of exploitation in the next 30 days, higher than 86.2% of scored vulnerabilities.

Priority
Routine

Not severe (CVSS 6.1, network access); no exploitation reported by the 5 checked sources

Source freshness unavailable

How is this decided?
CVSS score
6.1/10
010
Medium · v3.0 (NVD)
EPSS score
2.75%
0%100%
Low · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 20 · Related 4

Timeline

  1. 13-03-2018
    PublishedVulnerability first disclosed.
  2. 05-08-2024
    Last modifiedVulnerability information updated.

Description

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Cross Site Scripting (XSS) vulnerability in gem server display of homepage attribute that can result in XSS. This attack appear to be exploitable via the victim must browse to a malicious gem on a vulnerable gem server. This vulnerability appears to have been fixed in 2.7.6.

CVSS metrics

6 scores · 5 sources · 2 versions

EPSS trend

Probability

2.75%

Chance of exploitation in the next 30 days

Percentile

86%

Versus all other CVEs

30-day change

No change 0.00 pp

From 2.75% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, user interaction (CVSS vector). Other conditions: not stated in public data.

Ubuntu4 products
  • jruby< 1.5.6-9+deb8u2build0.14.04.1~esm2 | All versions (No fix recorded)
  • ruby1.9.1< 1.9.3.484-2ubuntu1.8
  • ruby2.0< 2.0.0.484-1ubuntu2.6
  • ruby2.3< 2.3.1-2~16.04.7
Debian3 products
RubyGems2 products
  • rubygems-update< 2.7.6
  • rubygems≤ 2.2.9 | ≤ 2.3.6 | ≤ 2.4.3 | ≤ 2.5.0
Org.jruby1 product
  • jruby-stdlib< 9.1.16.0

4 vendors · 10 products

References

27 links
Show all 27 references