CVE-2018-5223: atlassian crucible Improper Input Validation
Vulnerability summary
CVE-2018-5223 is a high (CVSS 7.2) Improper Input Validation vulnerability in atlassian crucible. EPSS estimates a 2.08% chance of exploitation in the next 30 days, higher than 81.5% of scored vulnerabilities.
Not severe (CVSS 7.2, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Timeline
- 29-03-2018PublishedVulnerability first disclosed.
- 16-09-2024Last modifiedVulnerability information updated.
Description
Fisheye and Crucible did not correctly check if a configured Mercurial repository URI contained values that the Windows operating system may consider argument parameters. An attacker who has permission to add a repository in Fisheye or Crucible can execute code of their choice on systems that run a vulnerable version of Fisheye or Crucible on the Windows operating system. All versions of Fisheye and Crucible before 4.4.6 (the fixed version for 4.4.x) and from 4.5.0 before 4.5.3 (the fixed version for 4.5.x) are affected by this vulnerability.
CVSS metrics
2 scores · 1 source · 2 versionsEPSS trend
Probability
2.08%
Chance of exploitation in the next 30 days
Percentile
82%
Versus all other CVEs
30-day change
No change 0.00 pp
From 2.08% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, administrative account, no user interaction (CVSS vector). Other conditions: not stated in public data.
Atlassian3 products
- crucible≥ 4.4.0, < 4.4.6 | ≥ 4.5.0, < 4.5.3
- fisheye≥ 4.4.0, < 4.4.6 | ≥ 4.5.0, < 4.5.3
- fisheye and crucible≥ unspecified, < 4.4.6 | ≥ 4.5.0, < unspecified | ≥ unspecified, < 4.5.3
1 vendor · 3 products