CVE-2019-8324: debian debian_linux Improper Control of Generation of Code
Vulnerability summary
CVE-2019-8324 is a high (CVSS 8.8) Improper Control of Generation of Code vulnerability in debian debian_linux. EPSS estimates a 3.22% chance of exploitation in the next 30 days, higher than 88.2% of scored vulnerabilities.
Not severe (CVSS 8.8, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 15 · Related 4Timeline
- 17-06-2019PublishedVulnerability first disclosed.
- 04-08-2024Last modifiedVulnerability information updated.
Description
An issue was discovered in RubyGems 2.6 and later through 3.0.2. A crafted gem with a multi-line name is not handled correctly. Therefore, an attacker could inject arbitrary code to the stub line of gemspec, which is eval-ed by code in ensure_loadable_spec during the preinstall check.
CVSS metrics
7 scores · 6 sources · 3 versions- OSV · AlpineEcosystem advisory · calculated8.8HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- OSV · UbuntuEcosystem advisory · calculated8.8HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- OSV · DebianEcosystem advisory · calculated8.8HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- OSV · RubygemsEcosystem advisory · calculated8.8HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS trend
Probability
3.22%
Chance of exploitation in the next 30 days
Percentile
88%
Versus all other CVEs
30-day change
No change 0.00 pp
From 3.22% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, user interaction (CVSS vector). Other conditions: not stated in public data.
Redhat67 products
- enterprise_linux8.0
- rh-ruby23-ruby< 0:2.3.8-70.el6 | < 0:2.3.8-70.el7
- rh-ruby23-ruby-debuginfo< 0:2.3.8-70.el6 | < 0:2.3.8-70.el7
- rh-ruby23-ruby-devel< 0:2.3.8-70.el6 | < 0:2.3.8-70.el7
- rh-ruby23-ruby-doc< 0:2.3.8-70.el6 | < 0:2.3.8-70.el7
Ubuntu5 products
- jruby< 1.5.6-9+deb8u2build0.14.04.1~esm2 | All versions (No fix recorded)
- ruby1.9.1< 1.9.3.484-2ubuntu1.14
- ruby2.0< 2.0.0.484-1ubuntu2.13
- ruby2.3< 2.3.1-2~16.04.12
- ruby2.5< 2.5.1-1ubuntu1.2
Debian3 products
- jruby< 9.1.17.0-3
- rubygems< 3.2.0~rc.1-1
- debian_linuxEOL9.0
RubyGems2 products
- rubygems-update≥ 2.6.0, < 2.7.9 | ≥ 3.0.0, < 3.0.2
- rubygems≥ 2.6.0, ≤ 3.0.2
Alpine1 product
- ruby< 2.4.6-r0 | < 2.5.5-r0
Opensuse1 product
- leapEOL15.0 | 15.1
6 vendors · 79 products
References
21 links- lists.opensuse.org/opensuse-security-announce/2019-07/msg00036.htmlVendor AdvisoryX Refsource SUSEWEBMailing ListThird Party Advisory
- access.redhat.com/errata/RHSA-2019:1972Vendor AdvisoryX Refsource REDHATAdvisoryWEBThird Party Advisory
- lists.debian.org/debian-lts-announce/2020/08/msg00027.htmlMailing ListX Refsource MLISTWEBThird Party Advisory