CVE-2021-21295: Possible request smuggling in HTTP/2 due missing validation
Vulnerability summary
CVE-2021-21295 is a medium (CVSS 5.9) vulnerability in apache kudu. EPSS estimates a 18.89% chance of exploitation in the next 30 days, higher than 97.2% of scored vulnerabilities.
Not severe (CVSS 5.9, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 12 · Related 7Timeline
- 09-03-2021PublishedVulnerability first disclosed.
- 08-10-2026Last modifiedVulnerability information updated.
Description
Netty is an open-source, asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In Netty (io.netty:netty-codec-http2) before version 4.1.60.Final there is a vulnerability that enables request smuggling. If a Content-Length header is present in the original HTTP/2 request, the field is not validated by `Http2MultiplexHandler` as it is propagated up. This is fine as long as the request is not proxied through as HTTP/1.1. If the request comes in as an HTTP/2 stream, gets converted into the HTTP/1.1 domain objects (`HttpRequest`, `HttpContent`, etc.) via `Http2StreamFrameToHttpObjectCodec `and then sent up to the child channel's pipeline and proxied through a remote peer as HTTP/1.1 this may result in request smuggling. In a proxy case, users may assume the content-length is validated somehow, which is not the case. If the request is forwarded to a backend channel that is a HTTP/1.1 connection, the Content-Length now has meaning and needs to be checked. An attacker can smuggle requests inside the body as it gets downgraded from HTTP/2 to HTTP/1.1. For an example attack refer to the linked GitHub Advisory. Users are only affected if all of this is true: `HTTP2MultiplexCodec` or `Http2FrameCodec` is used, `Http2StreamFrameToHttpObjectCodec` is used to convert to HTTP/1.1 objects, and these HTTP/1.1 objects are forwarded to another remote peer. This has been patched in 4.1.60.Final As a workaround, the user can do the validation by themselves by implementing a custom `ChannelInboundHandler` that is put in the `ChannelPipeline` behind `Http2StreamFrameToHttpObjectCodec`.
CVSS metrics
8 scores · 7 sources · 2 versions- OSV · UbuntuEcosystem advisory · calculated5.9MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
- OSV · DebianEcosystem advisory · calculated5.9MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
- OSV · WolfiEcosystem advisory · calculated5.9MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
- OSV · ChainguardEcosystem advisory · calculated5.9MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
- OSV · MavenEcosystem advisory · calculated5.9MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
- NVDNIST5.9MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS trend
Probability
18.89%
Chance of exploitation in the next 30 days
Percentile
97%
Versus all other CVEs
30-day change
No change 0.00 pp
From 18.89% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Chainguard4 products
- druidAll versions (No fix recorded)
- hadoop-fips-3.3.6All versions (No fix recorded)
- hadoop-fips-3.4.2All versions (No fix recorded)
- hadoop-fips-3.5All versions (No fix recorded)
Debian2 products
- netty< 1:4.1.48-3
- debian_linuxEOL10.0
Io.netty2 products
- nettyAll versions (No fix recorded)
- netty-codec-http2≥ 4.0.0, < 4.1.60.Final
Netapp2 products
Netty2 products
- io.netty:netty-codec-http2< 4.1.60.Final
- netty< 4.1.60
Opensuse1 product
- netty&distro=openSUSE Leap 15.2< 4.1.13-lp152.3.3.1
Oracle1 product
Org.jboss.netty1 product
- nettyAll versions (No fix recorded)
Quarkus1 product
- quarkus≤ 1.13.7
Ubuntu1 product
- nettyAll versions (No fix recorded) | < 1:4.0.34-1ubuntu0.1~esm1 | < 1:4.1.7-4ubuntu0.1+esm2 | < 1:4.1.45-1ubuntu0.1~esm1 | < 1:4.1.48-4+deb11u1build0.22.04.1
Wolfi1 product
- druidAll versions (No fix recorded)
12 vendors · 20 products
References
186 links- github.com/netty/netty/security/advisories/GHSA-wm47-8v5p-wjpjX Refsource CONFIRMREPORTAdvisoryWEBThird Party Advisory
- github.com/netty/netty/commit/89c241e3b1795ff257af4ad6eadc616cb2fb3dc4X Refsource MISCREPORTFIXWEBPatchVendor Advisory
Show all 100 references
- www.debian.org/security/2021/dsa-4885Vendor AdvisoryX Refsource DEBIANAdvisoryWEBThird Party Advisory
- lists.opensuse.org/archives/…Advisory
Showing 100 of 186.