7.4

CVE-2021-3450: CA certificate check bypass with X509_V_FLAG_X509_STRICT

Modified
AliasesALPINE-CVE-2021-3450UBUNTU-CVE-2021-3450DEBIAN-CVE-2021-3450
Published 25-03-2021Last modified 08-10-2026

Vulnerability summary

CVE-2021-3450 is a high (CVSS 7.4) Improper Certificate Validation vulnerability in fedoraproject fedora. EPSS estimates a 18.34% chance of exploitation in the next 30 days, higher than 97.2% of scored vulnerabilities.

Priority
Prioritisesevere

Severe, CVSS 7.4 (NVD); no exploitation reported by the 5 checked sources; EPSS 18% (FIRST, 03-11-2026)

Source freshness unavailable

How is this decided?
CVSS score
7.4/10
010
High · v3.1 (NVD)
EPSS score
18.34%
0%100%
Medium · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 15 · Related 9

Timeline

  1. 25-03-2021
    PublishedVulnerability first disclosed.
  2. 08-10-2026
    Last modifiedVulnerability information updated.

Description

The X509_V_FLAG_X509_STRICT flag enables additional security checks of the certificates present in a certificate chain. It is not set by default. Starting from OpenSSL version 1.1.1h a check to disallow certificates in the chain that have explicitly encoded elliptic curve parameters was added as an additional strict check. An error in the implementation of this check meant that the result of a previous check to confirm that certificates in the chain are valid CA certificates was overwritten. This effectively bypasses the check that non-CA certificates must not be able to issue other certificates. If a "purpose" has been configured then there is a subsequent opportunity for checks that the certificate is a valid CA. All of the named "purpose" values implemented in libcrypto perform this check. Therefore, where a purpose is set the certificate chain will still be rejected even when the strict flag has been used. A purpose is set by default in libssl client and server certificate verification routines, but it can be overridden or removed by an application. In order to be affected, an application must explicitly set the X509_V_FLAG_X509_STRICT verification flag and either not set a purpose for the certificate verification or, in the case of TLS client or server applications, override the default purpose. OpenSSL versions 1.1.1h and newer are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1k. OpenSSL 1.0.2 is not impacted by this issue. Fixed in OpenSSL 1.1.1k (Affected 1.1.1h-1.1.1j).

CVSS metrics

6 scores · 5 sources · 2 versions

EPSS trend

Probability

18.34%

Chance of exploitation in the next 30 days

Percentile

97%

Versus all other CVEs

30-day change

No change 0.00 pp

From 18.34% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Oracle13 products
Netapp5 products
Sonicwall4 products
Alpine3 products
  • openssl≥ 1.1.1h, < 1.1.1k-r0
  • openssl1.1-compat< 1.1.1k-r0
  • openssl3< 1.1.1k-r0
Tenable3 products
Mcafee2 products
Ubuntu2 products
  • openssl< 1.0.2g-1ubuntu4.19 | < 1.1.1-1ubuntu2.1~18.04.8 | < 1.1.1f-1ubuntu2.2
  • openssl1.0< 1.0.2n-1ubuntu5.6
Crates.Io1 product
  • openssl-src≥ 111.11.0, < 111.15.0
Debian1 product
  • openssl< 1.1.1k-1
Fedoraproject1 product
Freebsd1 product
Nodejs1 product
  • node.js≥ 10.0.0, < 10.24.1 | ≥ 12.0.0, < 12.22.1 | ≥ 14.0.0, < 14.16.1 | ≥ 15.0.0, < 15.14.0
Openssl1 product
  • opensslFixed in OpenSSL 1.1.1k (Affected 1.1.1h-1.1.1j) | ≥ 1.1.1h, < 1.1.1k
Windriver1 product
  • linuxna | 17.0 | 18.0 | 19.0

14 vendors · 39 products

References

35 links
Show all 35 references