3.7

CVE-2021-41136: Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') in puma

Modified
AliasesUBUNTU-CVE-2021-41136DEBIAN-CVE-2021-41136GHSA-48w2-rm65-62xx
Published 12-10-2021Last modified 27-05-2025

Vulnerability summary

CVE-2021-41136 is a low (CVSS 3.7) vulnerability in debian debian_linux. EPSS estimates a 1.20% chance of exploitation in the next 30 days, higher than 68.2% of scored vulnerabilities.

Priority
Routine

Not severe (CVSS 3.7, network access); no exploitation reported by the 5 checked sources

Source freshness unavailable

How is this decided?
CVSS score
3.7/10
010
Low · v3.1 (CVE.org)
EPSS score
1.20%
0%100%
Low · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 10 · Related 7

Timeline

  1. 12-10-2021
    PublishedVulnerability first disclosed.
  2. 27-05-2025
    Last modifiedVulnerability information updated.

Description

Puma is a HTTP 1.1 server for Ruby/Rack applications. Prior to versions 5.5.1 and 4.3.9, using `puma` with a proxy which forwards HTTP header values which contain the LF character could allow HTTP request smugggling. A client could smuggle a request through a proxy, causing the proxy to send a response back to another unknown client. The only proxy which has this behavior, as far as the Puma team is aware of, is Apache Traffic Server. If the proxy uses persistent connections and the client adds another request in via HTTP pipelining, the proxy may mistake it as the first request's body. Puma, however, would see it as two requests, and when processing the second request, send back a response that the proxy does not expect. If the proxy has reused the persistent connection to Puma to send another request for a different client, the second response from the first client will be sent to the second client. This vulnerability was patched in Puma 5.5.1 and 4.3.9. As a workaround, do not use Apache Traffic Server with `puma`.

CVSS metrics

6 scores · 5 sources · 2 versions

EPSS trend

Probability

1.20%

Chance of exploitation in the next 30 days

Percentile

68%

Versus all other CVEs

30-day change

No change 0.00 pp

From 1.20% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, low-privilege account, user interaction (CVSS vector). Other conditions: not stated in public data.

Debian2 products
Puma1 product
  • puma≥ 5.0.0, < 5.5.1 | < 4.3.9 | ≤ 4.3.8 | ≥ 5.0.0, ≤ 5.5.0
RubyGems1 product
  • puma≥ 5.0.0, < 5.5.1 | < 4.3.9
Ubuntu1 product
  • puma< 3.12.4-1ubuntu2 | < 5.5.2-2ubuntu2

4 vendors · 5 products

References

15 links
Show all 15 references