CVE-2022-1656: JupiterX Theme <= 2.0.6 and JupiterX Core <= 2.0.6 - Authenticated Arbitrary Plugin Deactivation and Settings Modification
Vulnerability summary
CVE-2022-1656 is a medium (CVSS 6.5) Improper Access Control vulnerability in artbees jupiter x. EPSS estimates a 0.53% chance of exploitation in the next 30 days, higher than 44.8% of scored vulnerabilities. Fixed in 2.0.7.
Timeline
- 13-06-2022PublishedVulnerability first disclosed.
- 13-02-2025Last modifiedVulnerability information updated.
Description
Vulnerable versions of the JupiterX Theme (<=2.0.6) allow any logged-in user, including subscriber-level users, to access any of the functions registered in lib/api/api/ajax.php, which also grant access to the jupiterx_api_ajax_ actions registered by the JupiterX Core Plugin (<=2.0.6). This includes the ability to deactivate arbitrary plugins as well as update the theme’s API key.
CVSS metrics
4 scores · 3 sources · 2 versions- CVE.orgCNA5.4MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:NDiffers
- NVDNIST5.4MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:NDiffers
EPSS trend
Probability
0.53%
Chance of exploitation in the next 30 days
Percentile
45%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.53% on 27-09-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Artbees3 products
- jupiter x2.0.6
- jupiter x core2.0.6 | ≤ 2.0.6
- jupiterx≤ 2.0.6
Wordpress2 products
- jupiterx-core≤ 2.0.6 (fixed in 2.0.7)
- jupiterx≤ 2.0.6 (fixed in 2.0.7)
2 vendors · 5 products