8.8

CVE-2023-22508: atlassian confluence_data_center

Modified
Published 18-07-2023Last modified 02-08-2024

Vulnerability summary

CVE-2023-22508 is a high (CVSS 8.8) vulnerability in atlassian confluence_data_center. EPSS estimates a 2.17% chance of exploitation in the next 30 days, higher than 82.2% of scored vulnerabilities. Fixed in 7.19.8, 8.2.0.

Priority
Routine

Not severe (CVSS 8.5, network access); no exploitation reported by the 5 checked sources

Source freshness unavailable

How is this decided?
CVSS score
8.8/10
010
High · v3.1 (NVD)
EPSS score
2.17%
0%100%
Low · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Timeline

  1. 18-07-2023
    PublishedVulnerability first disclosed.
  2. 02-08-2024
    Last modifiedVulnerability information updated.

Description

This High severity RCE (Remote Code Execution) vulnerability known as CVE-2023-22508 was introduced in version 6.1.0 of Confluence Data Center & Server. This RCE (Remote Code Execution) vulnerability, with a CVSS Score of 8.5, allows an authenticated attacker to execute arbitrary code which has high impact to confidentiality, high impact to integrity, high impact to availability, and no user interaction. Atlassian recommends that you upgrade your instance to avoid this bug using the following options: * Upgrade to a Confluence feature release greater than or equal to 8.2.0 (ie: 8.2, 8.2, 8.4, etc...) * Upgrade to a Confluence 7.19 LTS bugfix release greater than or equal to 7.19.8 (ie: 7.19.8, 7.19.9, 7.19.10, 7.19.11, etc...) * Upgrade to a Confluence 7.13 LTS bugfix release greater than or equal to 7.13.20 (Release available early August) See the release notes (https://confluence.atlassian.com/doc/confluence-release-notes-327.html ). You can download the latest version of Data Center & Server from the download center (https://www.atlassian.com/software/confluence/download-archives ). If you are unable to upgrade your instance please use the following guide to workaround the issue https://confluence.atlassian.com/confkb/how-to-disable-the-jmx-network-port-for-cve-2023-22508-1267761550.html This vulnerability was discovered by a private user and reported via our Bug Bounty program.

CVSS metrics

3 scores · 2 sources · 2 versions

EPSS trend

Probability

2.17%

Chance of exploitation in the next 30 days

Percentile

82%

Versus all other CVEs

30-day change

No change 0.00 pp

From 2.17% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

No weakness data has been published for this record.

Affected systems

Version check

Known conditions: network-reachable, low-privilege account, no user interaction (CVSS vector). Other conditions: not stated in public data.

Atlassian2 products
  • confluence_data_center≥ 6.1.0 (fixed in 7.19.8, 8.2.0) | ≥ 6.1.0, < 7.13.20 | ≥ 7.14.0, < 7.19.8 | ≥ 7.20.0, < 8.2.0
  • confluence_server≥ 6.1.0 (fixed in 7.19.8, 8.2.0) | ≥ 6.1.0, < 7.13.20 | ≥ 7.14.0, < 7.19.8 | ≥ 7.20.0, < 8.2.0

1 vendor · 2 products

References

1 links