CVE-2023-22526: atlassian confluence_data_center Improper Control of Generation of Code
Vulnerability summary
CVE-2023-22526 is a high (CVSS 8.8) Improper Control of Generation of Code vulnerability in atlassian confluence_data_center. EPSS estimates a 1.57% chance of exploitation in the next 30 days, higher than 75.3% of scored vulnerabilities. Fixed in 7.19.17, 8.5.5, 8.7.2.
Not severe (CVSS 7.2, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Timeline
- 16-01-2024PublishedVulnerability first disclosed.
- 20-06-2025Last modifiedVulnerability information updated.
Description
This High severity RCE (Remote Code Execution) vulnerability was introduced in version 7.19.0 of Confluence Data Center. This RCE (Remote Code Execution) vulnerability, with a CVSS Score of 7.2, allows an authenticated attacker to execute arbitrary code which has high impact to confidentiality, high impact to integrity, high impact to availability, and requires no user interaction. Atlassian recommends that Confluence Data Center customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: Confluence Data Center and Server 7.19: Upgrade to a release 7.19.17, or any higher 7.19.x release Confluence Data Center and Server 8.5: Upgrade to a release 8.5.5 or any higher 8.5.x release Confluence Data Center and Server 8.7: Upgrade to a release 8.7.2 or any higher release See the release notes ([https://confluence.atlassian.com/doc/confluence-release-notes-327.html]). You can download the latest version of Confluence Data Center from the download center ([https://www.atlassian.com/software/confluence/download-archives]). This vulnerability was discovered by m1sn0w and reported via our Bug Bounty program
CVSS metrics
3 scores · 2 sources · 2 versions- NVDNIST7.2HighCVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS trend
Probability
1.57%
Chance of exploitation in the next 30 days
Percentile
75%
Versus all other CVEs
30-day change
No change 0.00 pp
From 1.57% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, administrative account, no user interaction (CVSS vector). Other conditions: not stated in public data.
Atlassian2 products
- confluence_data_center≥ 7.13.0 (fixed in 7.19.17, 8.5.5, 8.7.2) | ≥ 7.19.0 (fixed in 7.19.17, 8.5.5, 8.7.2) | ≥ 8.0.0 (fixed in 7.19.17, 8.5.5, 8.7.2) | ≥ 8.1.0 (fixed in 7.19.17, 8.5.5, 8.7.2) | ≥ 8.2.0 (fixed in 7.19.17, 8.5.5, 8.7.2) | ≥ 8.3.0 (fixed in 7.19.17, 8.5.5, 8.7.2) | ≥ 8.4.0 (fixed in 7.19.17, 8.5.5, 8.7.2) | ≥ 8.5.0 (fixed in 7.19.17, 8.5.5, 8.7.2) | ≥ 8.6.0 (fixed in 7.19.17, 8.5.5, 8.7.2) | ≥ 8.7.1 (fixed in 7.19.17, 8.5.5, 8.7.2) | ≥ 7.19.0, < 7.19.17 | ≥ 8.5.0, < 8.5.5 | ≥ 8.7.0, < 8.7.2
- confluence_server≥ 7.19, < 7.19.17 | ≥ 8.5.0, < 8.5.5 | ≥ 8.7.0, ≤ 8.7.2
1 vendor · 2 products
References
2 links- jira.atlassian.com/browse/CONFSERVER-93516Permissions Required