CVE-2023-22527: Atlassian Confluence Data Center and Server Template Injection Vulnerability
Vulnerability summary
CVE-2023-22527 is a critical (CVSS 10.0) vulnerability in Atlassian Confluence Data Center and Server. It is known to be exploited: CISA lists it, first on 24-01-2024. It has been used in ransomware campaigns. EPSS estimates a 99.98% chance of exploitation in the next 30 days, higher than 99.9% of scored vulnerabilities. 3 public exploits are recorded. Fixed in 8.5.4, 8.6.0, 8.7.1 and 8.5.4, 8.6.0.
Known ransomware use (CISA, 24-01-2024)
Source freshness unavailable
How is this decided?Timeline
- 16-01-2024PublishedVulnerability first disclosed.
- 24-01-2024Added to CISA KEVExploitedAtlassian Confluence Data Center and Server Template Injection Vulnerability
- 14-02-2024CISA remediation dueDeadline passedApply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
- 21-10-2025Last modifiedVulnerability information updated.
Description
A template injection vulnerability on older versions of Confluence Data Center and Server allows an unauthenticated attacker to achieve RCE on an affected instance. Customers using an affected version must take immediate action. Most recent supported versions of Confluence Data Center and Server are not affected by this vulnerability as it was ultimately mitigated during regular version updates. However, Atlassian recommends that customers take care to install the latest version to protect their instances from non-critical vulnerabilities outlined in Atlassian’s January Security Bulletin.
CVSS metrics
3 scores · 2 sources · 2 versions- NVDNIST10.0CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS trend
Probability
99.98%
Chance of exploitation in the next 30 days
Percentile
100%
Versus all other CVEs
30-day change
No change 0.00 pp
From 99.98% on 04-10-2026
Known exploited
Compare KEV catalogs- Added
- 24-01-2024
- Federal due date
- 14-02-2024
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
CISA required action
Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable. confluence.atlassian.com/security/… nvd.nist.gov/vuln/detail/CVE-2023-22527
Public exploits
3 foundExploit Reference (packetstormsecurity.com)
Maturity: unknown
Exploit Reference (vicarius.io)
Maturity: unknown
Atlassian Confluence SSTI Injection
exploit/multi/http/atlassian_confluence_rce_cve_2023_22527
Maturity: weaponized
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Atlassian2 products
- confluence_data_center≥ 8.0.0 (fixed in 8.5.4, 8.6.0, 8.7.1) | ≥ 8.1.0 (fixed in 8.5.4, 8.6.0, 8.7.1) | ≥ 8.2.0 (fixed in 8.5.4, 8.6.0, 8.7.1) | ≥ 8.3.0 (fixed in 8.5.4, 8.6.0, 8.7.1) | ≥ 8.4.0 (fixed in 8.5.4, 8.6.0, 8.7.1) | ≥ 8.5.0 (fixed in 8.5.4, 8.6.0, 8.7.1) | ≥ 8.5.1 (fixed in 8.5.4, 8.6.0, 8.7.1) | ≥ 8.5.2 (fixed in 8.5.4, 8.6.0, 8.7.1) | ≥ 8.5.3 (fixed in 8.5.4, 8.6.0, 8.7.1) | ≥ 8.0.0, < 8.5.4 | 8.7.0
- confluence_server≥ 8.0.0 (fixed in 8.5.4, 8.6.0) | ≥ 8.1.0 (fixed in 8.5.4, 8.6.0) | ≥ 8.2.0 (fixed in 8.5.4, 8.6.0) | ≥ 8.3.0 (fixed in 8.5.4, 8.6.0) | ≥ 8.4.0 (fixed in 8.5.4, 8.6.0) | ≥ 8.5.0 (fixed in 8.5.4, 8.6.0) | ≥ 8.5.1 (fixed in 8.5.4, 8.6.0) | ≥ 8.5.2 (fixed in 8.5.4, 8.6.0) | ≥ 8.5.3 (fixed in 8.5.4, 8.6.0) | ≥ 8.0.0, < 8.5.4
1 vendor · 2 products
References
5 links- packetstormsecurity.com/files/176789/Atlassian-Confluence-SSTI-Injection.htmlExploitThird Party AdvisoryVDB Entry
- www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2023-22527Government ResourceUS Government Resource
- www.vicarius.io/vsociety/…Exploit