CVE-2024-21674: atlassian confluence_data_center Improper Control of Generation of Code
Vulnerability summary
CVE-2024-21674 is a high (CVSS 8.6) Improper Control of Generation of Code vulnerability in atlassian confluence_data_center. EPSS estimates a 1.77% chance of exploitation in the next 30 days, higher than 78.1% of scored vulnerabilities. Fixed in 7.19.18, 8.5.5, 8.7.2.
Severe, CVSS 8.6 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 2% (FIRST, 03-11-2026)
Source freshness unavailable
How is this decided?Timeline
- 16-01-2024PublishedVulnerability first disclosed.
- 29-08-2024Last modifiedVulnerability information updated.
Description
This High severity Remote Code Execution (RCE) vulnerability was introduced in version 7.13.0 of Confluence Data Center and Server. Remote Code Execution (RCE) vulnerability, with a CVSS Score of 8.6 and a CVSS Vector of CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N allows an unauthenticated attacker to expose assets in your environment susceptible to exploitation which has high impact to confidentiality, no impact to integrity, no impact to availability, and does not require user interaction. Atlassian recommends that Confluence Data Center and Server customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: * Confluence Data Center and Server 7.19: Upgrade to a release 7.19.18, or any higher 7.19.x release * Confluence Data Center and Server 8.5: Upgrade to a release 8.5.5 or any higher 8.5.x release * Confluence Data Center and Server 8.7: Upgrade to a release 8.7.2 or any higher release See the release notes (https://confluence.atlassian.com/doc/confluence-release-notes-327.html ). You can download the latest version of Confluence Data Center and Server from the download center (https://www.atlassian.com/software/confluence/download-archives ).
CVSS metrics
3 scores · 2 sources · 2 versions- NVDNIST8.6HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
EPSS trend
Probability
1.77%
Chance of exploitation in the next 30 days
Percentile
78%
Versus all other CVEs
30-day change
No change 0.00 pp
From 1.77% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Atlassian2 products
- confluence_data_center≥ 7.19.0 (fixed in 7.19.18, 8.5.5, 8.7.2) | ≥ 8.0.0 (fixed in 7.19.18, 8.5.5, 8.7.2) | ≥ 8.1.0 (fixed in 7.19.18, 8.5.5, 8.7.2) | ≥ 8.2.0 (fixed in 7.19.18, 8.5.5, 8.7.2) | ≥ 8.3.0 (fixed in 7.19.18, 8.5.5, 8.7.2) | ≥ 8.4.0 (fixed in 7.19.18, 8.5.5, 8.7.2) | ≥ 8.5.0 (fixed in 7.19.18, 8.5.5, 8.7.2) | ≥ 8.6.0 (fixed in 7.19.18, 8.5.5, 8.7.2) | ≥ 8.7.1 (fixed in 7.19.18, 8.5.5, 8.7.2) | ≥ 7.19.0, < 7.19.18 | ≥ 8.5.0, < 8.5.5 | ≥ 8.7.0, < 8.7.2
- confluence_server≥ 7.19.0 (fixed in 7.19.18, 8.5.5) | ≥ 8.0.0 (fixed in 7.19.18, 8.5.5) | ≥ 8.1.0 (fixed in 7.19.18, 8.5.5) | ≥ 8.2.0 (fixed in 7.19.18, 8.5.5) | ≥ 8.3.0 (fixed in 7.19.18, 8.5.5) | ≥ 8.4.0 (fixed in 7.19.18, 8.5.5) | ≥ 8.5.0 (fixed in 7.19.18, 8.5.5) | ≥ 8.6.0 (fixed in 7.19.18, 8.5.5) | ≥ 8.7.1 (fixed in 7.19.18, 8.5.5) | ≥ 7.19, < 7.19.18 | ≥ 8.5.0, < 8.5.5 | ≥ 8.7.0, ≤ 8.7.2
1 vendor · 2 products
References
2 links- jira.atlassian.com/browse/CONFSERVER-94066Permissions Required