CVE-2024-21677: atlassian confluence_data_center
Vulnerability summary
CVE-2024-21677 is a high (CVSS 8.8) vulnerability in atlassian confluence_data_center. EPSS estimates a 0.93% chance of exploitation in the next 30 days, higher than 60.5% of scored vulnerabilities. Fixed in 7.19.20, 8.5.7, 8.8.1.
Not severe (CVSS 8.3, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Timeline
- 19-03-2024PublishedVulnerability first disclosed.
- 13-03-2025Last modifiedVulnerability information updated.
Description
This High severity Path Traversal vulnerability was introduced in version 6.13.0 of Confluence Data Center. This Path Traversal vulnerability, with a CVSS Score of 8.3, allows an unauthenticated attacker to exploit an undefinable vulnerability which has high impact to confidentiality, high impact to integrity, high impact to availability, and requires user interaction. Atlassian recommends that Confluence Data Center and Server customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: Data Center Atlassian recommends that Confluence Data Center customers upgrade to the latest version and that Confluence Server customers upgrade to the latest 8.5.x LTS version. If you are unable to do so, upgrade your instance to one of the specified supported fixed versions See the release notes https://confluence.atlassian.com/doc/confluence-release-notes-327.html You can download the latest version of Confluence Data Center and Server from the download center https://www.atlassian.com/software/confluence/download-archives. This vulnerability was reported via our Bug Bounty program.
CVSS metrics
3 scores · 2 sources · 2 versions- NVDNIST8.3HighCVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H
EPSS trend
Probability
0.93%
Chance of exploitation in the next 30 days
Percentile
61%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.93% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, user interaction (CVSS vector). Other conditions: not stated in public data.
Atlassian2 products
- confluence_data_center≥ 6.13.0 (fixed in 7.19.20, 8.5.7, 8.8.1) | ≥ 7.19.0 (fixed in 7.19.20, 8.5.7, 8.8.1) | ≥ 7.20.0 (fixed in 7.19.20, 8.5.7, 8.8.1) | ≥ 8.0.0 (fixed in 7.19.20, 8.5.7, 8.8.1) | ≥ 8.1.0 (fixed in 7.19.20, 8.5.7, 8.8.1) | ≥ 8.2.0 (fixed in 7.19.20, 8.5.7, 8.8.1) | ≥ 8.3.0 (fixed in 7.19.20, 8.5.7, 8.8.1) | ≥ 8.4.0 (fixed in 7.19.20, 8.5.7, 8.8.1) | ≥ 8.5.0 (fixed in 7.19.20, 8.5.7, 8.8.1) | ≥ 8.6.0 (fixed in 7.19.20, 8.5.7, 8.8.1) | ≥ 8.7.1 (fixed in 7.19.20, 8.5.7, 8.8.1) | ≥ 8.8.0 (fixed in 7.19.20, 8.5.7, 8.8.1) | ≥ 6.13.0, < 7.19.20 | ≥ 7.20.0, < 8.5.7 | ≥ 8.6.0, < 8.8.1
- confluence_server≥ 6.13.0, < 7.19.20 | ≥ 7.20.0, < 8.5.7
1 vendor · 2 products