CVE-2024-21678: atlassian confluence_data_center
Vulnerability summary
CVE-2024-21678 is a high (CVSS 8.5) vulnerability in atlassian confluence_data_center. EPSS estimates a 0.47% chance of exploitation in the next 30 days, higher than 40.8% of scored vulnerabilities. Fixed in 7.19.18, 8.5.5, 8.7.2, 8.8.0.
Not severe (CVSS 8.5, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Timeline
- 20-02-2024PublishedVulnerability first disclosed.
- 31-10-2024Last modifiedVulnerability information updated.
Description
This High severity Stored XSS vulnerability was introduced in version 2.7.0 of Confluence Data Center. This Stored XSS vulnerability, with a CVSS Score of 8.5, allows an authenticated attacker to execute arbitrary HTML or JavaScript code on a victims browser which has high impact to confidentiality, low impact to integrity, no impact to availability, and requires no user interaction. Data Center Atlassian recommends that Confluence Data Center customers upgrade to the latest version. If you are unable to do so, upgrade your instance to one of the specified supported fixed versions: ||Affected versions||Fixed versions|| |from 8.7.0 to 8.7.1|8.8.0 recommended or 8.7.2| |from 8.6.0 to 8.6.1|8.8.0 recommended| |from 8.5.0 to 8.5.4 LTS|8.8.0 recommended or 8.5.5 LTS or 8.5.6 LTS| |from 8.4.0 to 8.4.5|8.8.0 recommended or 8.5.6 LTS| |from 8.3.0 to 8.3.4|8.8.0 recommended or 8.5.6 LTS| |from 8.2.0 to 8.2.3|8.8.0 recommended or 8.5.6 LTS| |from 8.1.0 to 8.1.4|8.8.0 recommended or 8.5.6 LTS| |from 8.0.0 to 8.0.4|8.8.0 recommended or 8.5.6 LTS| |from 7.20.0 to 7.20.3|8.8.0 recommended or 8.5.6 LTS| |from 7.19.0 to 7.19.17 LTS|8.8.0 recommended or 8.5.6 LTS or 7.19.18 LTS or 7.19.19 LTS| |from 7.18.0 to 7.18.3|8.8.0 recommended or 8.5.6 LTS or 7.19.19 LTS| |from 7.17.0 to 7.17.5|8.8.0 recommended or 8.5.6 LTS or 7.19.19 LTS| |Any earlier versions|8.8.0 recommended or 8.5.6 LTS or 7.19.19 LTS| Server Atlassian recommends that Confluence Server customers upgrade to the latest 8.5.x LTS version. If you are unable to do so, upgrade your instance to one of the specified supported fixed versions: ||Affected versions||Fixed versions|| |from 8.5.0 to 8.5.4 LTS|8.5.5 LTS or 8.5.6 LTS recommended | |from 8.4.0 to 8.4.5|8.5.6 LTS recommended| |from 8.3.0 to 8.3.4|8.5.6 LTS recommended| |from 8.2.0 to 8.2.3|8.5.6 LTS recommended| |from 8.1.0 to 8.1.4|8.5.6 LTS recommended| |from 8.0.0 to 8.0.4|8.5.6 LTS recommended| |from 7.20.0 to 7.20.3|8.5.6 LTS recommended| |from 7.19.0 to 7.19.17 LTS|8.5.6 LTS recommended or 7.19.18 LTS or 7.19.19 LTS| |from 7.18.0 to 7.18.3|8.5.6 LTS recommended or 7.19.19 LTS| |from 7.17.0 to 7.17.5|8.5.6 LTS recommended or 7.19.19 LTS| |Any earlier versions|8.5.6 LTS recommended or 7.19.19 LTS| See the release notes ([https://confluence.atlassian.com/doc/confluence-release-notes-327.html]). You can download the latest version of Confluence Data Center from the download center ([https://www.atlassian.com/software/confluence/download-archives]). This vulnerability was reported via our Bug Bounty program.
CVSS metrics
3 scores · 2 sources · 2 versions- NVDNIST8.5HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
EPSS trend
Probability
0.47%
Chance of exploitation in the next 30 days
Percentile
41%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.47% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, low-privilege account, no user interaction (CVSS vector). Other conditions: not stated in public data.
Atlassian2 products
- confluence_data_center≥ 2.7.0 (fixed in 7.19.18, 8.5.5, 8.7.2, 8.8.0) | ≥ 7.13.0 (fixed in 7.19.18, 8.5.5, 8.7.2, 8.8.0) | ≥ 7.19.0 (fixed in 7.19.18, 8.5.5, 8.7.2, 8.8.0) | ≥ 7.20.0 (fixed in 7.19.18, 8.5.5, 8.7.2, 8.8.0) | ≥ 8.0.0 (fixed in 7.19.18, 8.5.5, 8.7.2, 8.8.0) | ≥ 8.1.0 (fixed in 7.19.18, 8.5.5, 8.7.2, 8.8.0) | ≥ 8.2.0 (fixed in 7.19.18, 8.5.5, 8.7.2, 8.8.0) | ≥ 8.3.0 (fixed in 7.19.18, 8.5.5, 8.7.2, 8.8.0) | ≥ 8.4.0 (fixed in 7.19.18, 8.5.5, 8.7.2, 8.8.0) | ≥ 8.5.0 (fixed in 7.19.18, 8.5.5, 8.7.2, 8.8.0) | ≥ 8.6.0 (fixed in 7.19.18, 8.5.5, 8.7.2, 8.8.0) | ≥ 8.7.1 (fixed in 7.19.18, 8.5.5, 8.7.2, 8.8.0) | < 7.19.19 | ≥ 7.20.0, < 8.5.5 | ≥ 8.6.0, < 8.7.2
- confluence_server< 7.19.19 | ≥ 7.20.0, < 8.5.5
1 vendor · 2 products