CVE-2024-21690: atlassian confluence_data_center
Vulnerability summary
CVE-2024-21690 is a high (CVSS 8.2) vulnerability in atlassian confluence_data_center. EPSS estimates a 0.75% chance of exploitation in the next 30 days, higher than 54.9% of scored vulnerabilities.
Not severe (CVSS 7.1, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Timeline
- 21-08-2024PublishedVulnerability first disclosed.
- 06-11-2024Last modifiedVulnerability information updated.
Description
This High severity Reflected XSS and CSRF (Cross-Site Request Forgery) vulnerability was introduced in versions 7.19.0, 7.20.0, 8.0.0, 8.1.0, 8.2.0, 8.3.0, 8.4.0, 8.5.0, 8.6.0, 8.7.1, 8.8.0, and 8.9.0 of Confluence Data Center and Server. This Reflected XSS and CSRF (Cross-Site Request Forgery) vulnerability, with a CVSS Score of 7.1, allows an unauthenticated attacker to execute arbitrary HTML or JavaScript code on a victims browser and force a end user to execute unwanted actions on a web application in which they're currently authenticated which has high impact to confidentiality, low impact to integrity, no impact to availability, and requires user interaction. Atlassian recommends that Confluence Data Center and Server customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: * Confluence Data Center and Server 7.19: Upgrade to a release greater than or equal to 7.19.26 * Confluence Data Center and Server 8.5: Upgrade to a release greater than or equal to 8.5.14 * Confluence Data Center and Server 9.0: Upgrade to a release greater than or equal to 9.0.1 See the release notes (https://confluence.atlassian.com/doc/confluence-release-notes-327.html). You can download the latest version of Confluence Data Center and Server from the download center (https://www.atlassian.com/software/confluence/download-archives). This vulnerability was reported via our Bug Bounty program.
CVSS metrics
3 scores · 2 sources · 2 versions- NVDNIST7.1HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N
EPSS trend
Probability
0.75%
Chance of exploitation in the next 30 days
Percentile
55%
Versus all other CVEs
30-day change
Decrease -0.01 pp
From 0.76% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, user interaction (CVSS vector). Other conditions: not stated in public data.
Atlassian2 products
- confluence_data_center8.9.0 to 8.9.5 | 8.8.0 to 8.8.1 | 8.7.1 to 8.7.2 | 8.6.0 to 8.6.2 | 8.5.0 to 8.5.12 | 8.4.0 to 8.4.5 | 8.3.0 to 8.3.4 | 8.2.0 to 8.2.3 | 8.1.0 to 8.1.4 | 8.0.0 to 8.0.4 | 7.20.0 to 7.20.3 | ≥ 7.19.0, ≤ 7.19.25 | ≥ 7.20.0, ≤ 7.20.3 | ≥ 8.0.0, ≤ 8.0.4 | ≥ 8.1.0, ≤ 8.1.4 | ≥ 8.2.0, ≤ 8.2.3 | ≥ 8.3.0, ≤ 8.3.4 | ≥ 8.4.0, ≤ 8.4.5 | ≥ 8.5.0, ≤ 8.5.12 | ≥ 8.6.0, ≤ 8.6.2 | ≥ 8.7.1, ≤ 8.7.2 | ≥ 8.8.0, ≤ 8.8.1 | ≥ 8.9.0, ≤ 8.9.4
- confluence_server8.5.0 to 8.5.12 | 8.4.0 to 8.4.5 | 8.3.0 to 8.3.4 | 8.2.0 to 8.2.3 | 8.1.0 to 8.1.4 | 8.0.0 to 8.0.4 | 7.20.0 to 7.20.3 | ≥ 7.19.0, ≤ 7.19.25 | ≥ 7.20.0, ≤ 7.20.3 | ≥ 8.0.0, ≤ 8.0.4 | ≥ 8.1.0, ≤ 8.1.4 | ≥ 8.2.0, ≤ 8.2.3 | ≥ 8.3.0, ≤ 8.3.4 | ≥ 8.4.0, ≤ 8.4.5 | ≥ 8.5.0, ≤ 8.5.12 | ≥ 8.6.0, ≤ 8.6.2 | ≥ 8.7.1, ≤ 8.7.2 | ≥ 8.8.0, ≤ 8.8.1 | ≥ 8.9.0, ≤ 8.9.4
1 vendor · 2 products