CVE-2024-56137: MaxKB RCE vulnerability in function library
Vulnerability summary
CVE-2024-56137 is a high (CVSS 7.2) vulnerability in 1panel-dev maxkb. EPSS estimates a 0.81% chance of exploitation in the next 30 days, higher than 56.9% of scored vulnerabilities. 1 public exploit is recorded.
Not severe (CVSS 6.8, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Timeline
- 02-01-2025PublishedVulnerability first disclosed.
- 02-01-2025Last modifiedVulnerability information updated.
Description
MaxKB, which stands for Max Knowledge Base, is an open source knowledge base question-answering system based on a large language model and retrieval-augmented generation (RAG). Prior to version 1.9.0, a remote command execution vulnerability exists in the module of function library. The vulnerability allow privileged users to execute OS command in custom scripts. The vulnerability has been fixed in v1.9.0.
CVSS metrics
2 scores · 2 sources · 1 version- CVE.orgCNA6.8MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:HDiffers
EPSS trend
Probability
0.81%
Chance of exploitation in the next 30 days
Percentile
57%
Versus all other CVEs
30-day change
Increase +0.02 pp
From 0.79% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
1 foundMaxkb
Maturity: poc
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, administrative account, user interaction (CVSS vector). Other conditions: not stated in public data.
1panel-dev1 product
- maxkb< 1.9.0
Maxkb1 product
- maxkb< 1.9.0
2 vendors · 2 products
References
1 links- github.com/1Panel-dev/MaxKB/security/advisories/GHSA-76w2-2g72-cg85X Refsource CONFIRMExploitVendor Advisory