6.2

CVE-2025-27789: Inefficient RexExp complexity in generated code with .replace when transpiling named capturing groups

Deferred
AliasesUBUNTU-CVE-2025-27789CGA-2qj9-3j4v-4jmgCGA-3726-6g3g-hmjm
Published 11-03-2025Last modified 11-03-2025

Vulnerability summary

CVE-2025-27789 is a medium (CVSS 6.2) vulnerability in babel. EPSS estimates a 0.56% chance of exploitation in the next 30 days, higher than 46.8% of scored vulnerabilities.

Priority
Routine

Not severe (CVSS 6.2, local access); no exploitation reported by the 5 checked sources

Source freshness unavailable

How is this decided?
CVSS score
6.2/10
010
Medium · v3.1 (CVE.org)
EPSS score
0.56%
0%100%
Low · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 0 · Related 11

Timeline

  1. 11-03-2025
    PublishedVulnerability first disclosed.
  2. 11-03-2025
    Last modifiedVulnerability information updated.

Description

Babel is a compiler for writing next generation JavaScript. When using versions of Babel prior to 7.26.10 and 8.0.0-alpha.17 to compile regular expression named capturing groups, Babel will generate a polyfill for the `.replace` method that has quadratic complexity on some specific replacement pattern strings (i.e. the second argument passed to `.replace`). Generated code is vulnerable if all the following conditions are true: Using Babel to compile regular expression named capturing groups, using the `.replace` method on a regular expression that contains named capturing groups, and the code using untrusted strings as the second argument of `.replace`. This problem has been fixed in `@babel/helpers` and `@babel/runtime` 7.26.10 and 8.0.0-alpha.17. It's likely that individual users do not directly depend on `@babel/helpers`, and instead depend on `@babel/core` (which itself depends on `@babel/helpers`). Upgrading to `@babel/core` 7.26.10 is not required, but it guarantees use of a new enough `@babel/helpers` version. Note that just updating Babel dependencies is not enough; one will also need to re-compile the code. No known workarounds are available.

CVSS metrics

6 scores · 6 sources · 1 version

EPSS trend

Probability

0.56%

Chance of exploitation in the next 30 days

Percentile

47%

Versus all other CVEs

30-day change

No change 0.00 pp

From 0.56% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: local access, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Chainguard77 products
  • arangodb-3.11< 3.11.14.5-r26
  • arangodb-3.12< 3.12.11-r0
  • argo-workflows< 3.6.5-r1
  • gitlab-rails-ce-18.1All versions (No fix recorded)
  • gitlab-rails-ce-18.10All versions (No fix recorded)
Wolfi22 products
  • argo-workflows< 3.6.5-r1
  • jitsucom-jitsu< 2.8.6-r3
  • jitsucom-jitsu-console< 2.8.6-r3
  • jitsucom-jitsu-rotor< 2.8.6-r3
  • katib-earlystopping< 0.19.0-r31
@babel4 products
  • helpers< 7.26.10 | ≥ 8.0.0-alpha.0, < 8.0.0-alpha.17
  • runtime< 7.26.10 | ≥ 8.0.0-alpha.0, < 8.0.0-alpha.17
  • runtime-corejs2< 7.26.10 | ≥ 8.0.0-alpha.0, < 8.0.0-alpha.17
  • runtime-corejs3< 7.26.10 | ≥ 8.0.0-alpha.0, < 8.0.0-alpha.17
Ubuntu2 products
  • node-babelAll versions (No fix recorded)
  • node-babel7All versions (No fix recorded)
Babel1 product
  • babel< 7.26.10 | ≥ 8.0.0-alpha.0, < 8.0.0-alpha.17

5 vendors · 106 products

References

8 links