CVE-2026-44728: Improper Control of Generation of Code when compiling specifically crafted malicious code with @babel/plugin-transform-modules-systemjs
Vulnerability summary
CVE-2026-44728 is a high (CVSS 8.2) Improper Control of Generation of Code vulnerability in babel. EPSS estimates a 0.13% chance of exploitation in the next 30 days, higher than 2.2% of scored vulnerabilities.
Not severe (CVSS 8.2, local access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 0 · Related 1Timeline
- 26-05-2026PublishedVulnerability first disclosed.
- 28-05-2026Last modifiedVulnerability information updated.
Description
Babel is a compiler for writing next generation JavaScript. From 7.12.0 to before 7.29.4 and 8.0.0-alpha.13, using Babel to compile code that was specifically crafted by an attacker can cause Babel to generate output code that executes arbitrary code. This vulnerability is fixed in 7.29.4 and 8.0.0-alpha.13.
CVSS metrics
7 scores · 7 sources · 1 version- OSV · UbuntuEcosystem advisory · calculated7.8HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HDiffers
- OSV · DebianEcosystem advisory · calculated7.8HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HDiffers
- OSV · WolfiEcosystem advisory · calculated8.2HighCVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
- OSV · NpmEcosystem advisory · calculated8.2HighCVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
- OSV · ChainguardEcosystem advisory · calculated8.2HighCVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
- NVDNIST7.8HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HDiffers
EPSS trend
Probability
0.13%
Chance of exploitation in the next 30 days
Percentile
2%
Versus all other CVEs
30-day change
Decrease -0.05 pp
From 0.18% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root cause- CWE-94Improper Control of Generation of CodeThe product constructs all or part of a code segment using externally-influenced input from an upstream component, but it does not neutralize or incorrectly neutralizes special elements that could modify the syntax or behavior of the intended code segment.
- CWE-843Access of Resource Using Incompatible TypeThe product allocates or initializes a resource such as a pointer, object, or variable using one type, but it later accesses that resource using a type that is incompatible with the original type.
Affected systems
Known conditions: local access, low-privilege account, user interaction (CVSS vector). Other conditions: not stated in public data.
Chainguard47 products
- airflow-2All versions (No fix recorded)
- airflow-core-2All versions (No fix recorded)
- arangodb-3.11< 3.11.14.5-r8
- arangodb-3.12< 3.12.9.4-r16
- argo-workflows-ui-3.6< 3.6.19-r6
Wolfi12 products
- argo-workflows-ui-3.7< 3.7.14-r1
- katib-earlystopping< 0.19.0-r31
- katib-suggestion-goptuna-compatAll versions (No fix recorded)
- katib-suggestion-hyperband< 0.19.0-r31
- katib-suggestion-hyperopt< 0.19.0-r40 | < 0.19.0-r31
@babel2 products
- plugin-transform-modules-systemjs≥ 7.12.0, < 7.29.4 | ≥ 8.0.0-alpha.0, < 8.0.0-alpha.13
- plugin-transform-modules-systemjs≥ 7.12.0, < 7.29.4 | ≥ 8.0.0-alpha.0, < 8.0.0-alpha.13
Babel1 product
- babel≥ 8.0.0-alpha.0, < 8.0.0-alpha.13 | ≥ 7.12.0, < 7.29.4 | 8.0.0:alpha0 | 8.0.0:alpha1 | 8.0.0:alpha10 | 8.0.0:alpha11 | 8.0.0:alpha12 | 8.0.0:alpha2 | 8.0.0:alpha3 | 8.0.0:alpha4 | 8.0.0:alpha5 | 8.0.0:alpha6 | 8.0.0:alpha7 | 8.0.0:alpha8 | 8.0.0:alpha9
Debian1 product
- node-babel7All versions (No fix recorded) | < 8.0.4+ds1+~cs177.303.116-2
Ubuntu1 product
- node-babel7All versions (No fix recorded)
6 vendors · 64 products
References
7 links- github.com/babel/babel/security/advisories/GHSA-fv7c-fp4j-7gwpX Refsource CONFIRMREPORTAdvisoryWEBMitigationVendor Advisory
- github.com/babel/babelPACKAGE