CVE-2026-16221: fast-uri vulnerable to host confusion via literal backslash authority delimiter
Vulnerability summary
CVE-2026-16221 is a high (CVSS 7.5) Interpretation Conflict vulnerability in fast-uri. EPSS estimates a 0.44% chance of exploitation in the next 30 days, higher than 37.8% of scored vulnerabilities.
Severe, CVSS 7.5 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 0% (FIRST, 03-11-2026)
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 2 · Related 1Timeline
- 19-07-2026PublishedVulnerability first disclosed.
- 20-07-2026Last modifiedVulnerability information updated.
Description
Impact: fast-uri versions from 2.3.1 through 4.1.0 (including the 3.x line up to 3.1.3 and the 2.x line up to 2.4.2) do not treat a literal backslash character (U+005C) as an authority delimiter. Node's native WHATWG URL parser, used by fetch, undici, and Node's http and https clients, normalizes the backslash to a forward slash for special schemes such as http, https, ws, wss, ftp, and file. As a result, the two parsers extract different hosts from the same input string. Applications that use fast-uri to enforce host-based policy such as allowlists, denylists, loopback or SSRF filtering, redirect validation, or outbound proxy routing before passing the same URL into Node's URL or fetch consumers can be steered to an unintended destination, including cloud metadata endpoints, loopback, or internal hosts. Patches: upgrade to fast-uri 4.1.1, 3.1.4, or 2.4.3. Workarounds: none.
CVSS metrics
7 scores · 7 sources · 1 version- OSV · UbuntuEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- OSV · DebianEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- OSV · WolfiEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- OSV · NpmEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- OSV · ChainguardEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- NVDNIST7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS trend
Probability
0.44%
Chance of exploitation in the next 30 days
Percentile
38%
Versus all other CVEs
30-day change
Increase +0.18 pp
From 0.25% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Chainguard114 products
- airflow-2All versions (No fix recorded)
- airflow-core-2All versions (No fix recorded)
- arangodb-3.12< 3.12.9.4-r15
- argo-workflows-ui-3.7< 3.7.17-r0
- argo-workflows-ui-4.0< 4.0.8-r0 | < 4.0.11-r0
Wolfi25 products
- argo-workflows-ui-3.7< 3.7.17-r0
- argo-workflows-ui-4.0< 4.0.8-r0 | < 4.0.11-r0
- jupyter-base-notebook< 7.6.3-r2
- langfuse-3< 3.224.1-r0
- langfuse-3-compat< 3.225.7-r6
Debian1 product
- node-ajvAll versions (No fix recorded) | < 8.20.0~ds+~cs7.1.2-1
Fast-uri1 product
- fast-uri≥ 2.3.1, < 2.4.3 | ≥ 3.0.0, < 3.1.4 | ≥ 4.0.0, < 4.1.1
Npm1 product
- fast-uri≥ 2.3.1, < 2.4.3 | ≥ 3.0.0, < 3.1.4 | ≥ 4.0.0, < 4.1.1
Openjsf1 product
- fast-uri≥ 2.3.1, < 2.4.3 | ≥ 3.0.0, < 3.1.4 | ≥ 4.0.0, < 4.1.1
Ubuntu1 product
- node-ajvAll versions (No fix recorded)
7 vendors · 144 products