CVE-2026-26007: cryptography Subgroup Attack Due to Missing Subgroup Validation for SECT Curves
Vulnerability summary
CVE-2026-26007 is a high (CVSS 8.2) vulnerability in cryptography.io cryptography. EPSS estimates a 0.39% chance of exploitation in the next 30 days, higher than 33.1% of scored vulnerabilities.
Severe, CVSS 8.2 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 0% (FIRST, 03-11-2026)
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 12 · Related 5Timeline
- 10-02-2026PublishedVulnerability first disclosed.
- 16-09-2026Last modifiedVulnerability information updated.
Description
cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. Prior to 46.0.5, the public_key_from_numbers (or EllipticCurvePublicNumbers.public_key()), EllipticCurvePublicNumbers.public_key(), load_der_public_key() and load_pem_public_key() functions do not verify that the point belongs to the expected prime-order subgroup of the curve. This missing validation allows an attacker to provide a public key point P from a small-order subgroup. This can lead to security issues in various situations, such as the most commonly used signature verification (ECDSA) and shared key negotiation (ECDH). When the victim computes the shared secret as S = [victim_private_key]P via ECDH, this leaks information about victim_private_key mod (small_subgroup_order). For curves with cofactor > 1, this reveals the least significant bits of the private key. When these weak public keys are used in ECDSA , it's easy to forge signatures on the small subgroup. Only SECT curves are impacted by this. This vulnerability is fixed in 46.0.5.
CVSS metrics
11 scores · 8 sources · 2 versions- OSV · UbuntuEcosystem advisory · calculated8.2HighCVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- OSV · WolfiEcosystem advisory · calculated8.2HighCVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- OSV · ChainguardEcosystem advisory · calculated8.2HighCVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- NVDNIST8.2HighCVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- OSV · AlpineEcosystem advisory · calculated6.5MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:NDiffers
- OSV · PypiEcosystem advisory · calculated6.5MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:NDiffers
- OSV · UbuntuEcosystem advisory · calculated6.5MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:NDiffers
- OSV · DebianEcosystem advisory · calculated6.5MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:NDiffers
- NVDNIST6.5MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:NDiffers
EPSS trend
Probability
0.39%
Chance of exploitation in the next 30 days
Percentile
33%
Versus all other CVEs
30-day change
Increase +0.04 pp
From 0.35% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root cause- CWE-345Insufficient Verification of Data AuthenticityThe product does not sufficiently verify the origin or authenticity of data, in a way that causes it to accept invalid data.
- CWE-354Improper Validation of Integrity Check ValueThe product does not validate or incorrectly validates the integrity check values or "checksums" of a message.
Affected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Chainguard66 products
- airflow-2< 2.11.2-r5
- airflow-3< 3.1.7-r1
- airflow-core-2< 2.11.0-r14
- airflow-core-3< 3.1.7-r1
- ansible-operator-fips< 1.42.0-r6
Wolfi22 products
- airflow-3< 3.1.7-r1
- dask-kubernetes< 2025.7.0-r8
- datadog-agent-7.72-core-integrations< 7.72.4-r27
- datadog-agent-7.73-core-integrations< 7.73.3-r23
- datadog-agent-7.74-core-integrations< 7.74.1-r19
Suse2 products
- python-cryptography&distro=SUSE Linux Micro 6.0< 42.0.4-3.1
- python-cryptography&distro=SUSE Linux Micro 6.1< 42.0.4-slfo.1.1_3.1
Alpine1 product
- py3-cryptography< 46.0.5-r0
Cryptography.io1 product
- cryptography< 46.0.5
Debian1 product
- python-cryptographyAll versions (No fix recorded) | < 43.0.0-3+deb13u1 | < 46.0.5-1
Opensuse1 product
- python-cryptography&distro=openSUSE Tumbleweed< 46.0.5-1.1
Pyca1 product
- cryptography< 46.0.5
PyPI1 product
- cryptography< 46.0.5
Ubuntu1 product
- python-cryptography< 3.4.8-1ubuntu2.3 | < 41.0.7-4ubuntu0.3 | < 43.0.0-1ubuntu1.1 | < 1.2.3-1ubuntu0.3+esm3 | < 2.1.4-1ubuntu1.4+esm3 | < 2.8-3ubuntu0.3+esm2
10 vendors · 97 products
References
40 links- github.com/pyca/cryptography/security/advisories/GHSA-r6ph-v2qm-q3c2X Refsource CONFIRMWEBAdvisoryREPORTVendor Advisory
- github.com/pyca/cryptography/commit/0eebb9dbb6343d9bc1d91e5a2482ed4e054a6d8cX Refsource MISCWEBFIXPatch
Show all 40 references
- github.com/pyca/cryptographyPACKAGE