CVE-2026-39426: MaxKB: Stored XSS via Unsanitized iframe_render Parsing
Vulnerability summary
CVE-2026-39426 is a medium (CVSS 5.4) vulnerability in 1panel-dev maxkb. EPSS estimates a 0.19% chance of exploitation in the next 30 days, higher than 9% of scored vulnerabilities.
Not severe (CVSS 5.1, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Timeline
- 14-04-2026PublishedVulnerability first disclosed.
- 16-04-2026Last modifiedVulnerability information updated.
Description
MaxKB is an open-source AI assistant for enterprise. Versions 2.7.1 and below contain a Stored Cross-Site Scripting (XSS) vulnerability where the frontend's MdRenderer.vue component parses custom <iframe_render> tags from LLM responses or Application Prologue configurations, bypassing standard Markdown sanitization and XSS filtering. The unsanitized HTML content is passed to the IframeRender.vue component, which renders it directly into an <iframe> via the srcdoc attribute configured with sandbox="allow-scripts allow-same-origin". This can be a dangerous combination, allowing injected scripts to escape the iframe and execute JavaScript in the parent window using window.parent. Since the Prologue is rendered for any user visiting an application's chat interface, this results in a high-impact Stored XSS that can lead to session hijacking, unauthorized actions, and sensitive data exposure. This issue has been fixed in version 2.8.0.
CVSS metrics
3 scores · 2 sources · 2 versions- NVDNIST5.1MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
EPSS trend
Probability
0.19%
Chance of exploitation in the next 30 days
Percentile
9%
Versus all other CVEs
30-day change
Decrease -0.05 pp
From 0.25% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, low-privilege account, user interaction (CVSS vector). Other conditions: not stated in public data.
1panel-dev1 product
- maxkb< 2.8.0
Maxkb1 product
- maxkb< 2.8.0
2 vendors · 2 products
References
2 links- github.com/1Panel-dev/MaxKB/security/advisories/GHSA-q2qg-43vq-f2wvX Refsource CONFIRMVendor Advisory