CVE-2026-4800: lodash vulnerable to Code Injection via `_.template` imports key names
Vulnerability summary
CVE-2026-4800 is a high (CVSS 8.1) Improper Control of Generation of Code vulnerability in lodash. EPSS estimates a 2.81% chance of exploitation in the next 30 days, higher than 86.5% of scored vulnerabilities.
Severe, CVSS 8.1 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 3% (FIRST, 03-11-2026)
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 11 · Related 2Timeline
- 31-03-2026PublishedVulnerability first disclosed.
- 14-09-2026Last modifiedVulnerability information updated.
Description
Impact: The fix for CVE-2021-23337 (https://github.com/advisories/GHSA-35jh-r3h4-6jhm) added validation for the variable option in _.template but did not apply the same validation to options.imports key names. Both paths flow into the same Function() constructor sink. When an application passes untrusted input as options.imports key names, an attacker can inject default-parameter expressions that execute arbitrary code at template compilation time. Additionally, _.template uses assignInWith to merge imports, which enumerates inherited properties via for..in. If Object.prototype has been polluted by any other vector, the polluted keys are copied into the imports object and passed to Function(). Patches: Users should upgrade to version 4.18.0. Workarounds: Do not pass untrusted input as key names in options.imports. Only use developer-controlled, static key names.
CVSS metrics
5 scores · 5 sources · 1 version- OSV · Red hatEcosystem advisory · calculated8.1HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- OSV · UbuntuEcosystem advisory · calculated9.8CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HDiffers
- OSV · DebianEcosystem advisory · calculated9.8CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HDiffers
- OSV · WolfiEcosystem advisory · calculated8.1HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS trend
Probability
2.81%
Chance of exploitation in the next 30 days
Percentile
87%
Versus all other CVEs
30-day change
Increase +0.19 pp
From 2.62% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Chainguard36 products
- argo-workflows-ui-3.7< 3.7.13-r0
- argo-workflows-ui-4.0< 4.0.4-r0
- code-server< 4.112.0-r2
- jitsucom-jitsu-console< 2.11.0-r19
- json-server< 0.17.4-r6
Wolfi36 products
- argo-workflows-ui-3.7< 3.7.13-r0
- argo-workflows-ui-4.0< 4.0.4-r0
- code-server< 4.112.0-r2
- jitsucom-jitsu-console< 2.11.0-r19
- json-server< 0.17.4-r6
Redhat13 products
- cockpit< 0:356.1-1.el9_8
- cockpit-bridge< 0:356.1-1.el9_8
- cockpit-debuginfo< 0:356.1-1.el9_8
- cockpit-debugsource< 0:356.1-1.el9_8
- cockpit-doc< 0:356.1-1.el9_8
Lodash4 products
- lodash≥ 4.0.0, < 4.18.0
- lodash-amd≥ 4.0.0, < 4.18.0
- lodash-es≥ 4.0.0, < 4.18.0
- lodash.template≥ 4.0.0, < 4.18.0
Debian1 product
- node-lodash< 4.17.21+dfsg+~cs8.31.198.20210220-9+deb12u1 | < 4.17.21+dfsg+~cs8.31.198.20210220-9+deb13u1 | < 4.18.1+dfsg-1
Ubuntu1 product
- node-lodash< 2.4.1+dfsg-3ubuntu0.1~esm1 | < 4.17.4+dfsg-1ubuntu0.1~esm1 | < 4.17.15+dfsg-2ubuntu0.1~esm1 | < 4.17.21+dfsg+~cs8.31.198.20210220-5ubuntu0.1~esm1 | < 4.17.21+dfsg+~cs8.31.198.20210220-9ubuntu0.24.04.1~esm1 | < 4.17.21+dfsg+~cs8.31.198.20210220-9ubuntu0.25.10.1 | < 4.17.23+dfsg-1ubuntu0.1~esm1
6 vendors · 91 products