CVE-2026-54149: MaxKB MCP tool import validation bypass allows post-authentication remote code execution
Vulnerability summary
CVE-2026-54149 is a high (CVSS 8.8) vulnerability in 1panel-dev maxkb. EPSS estimates a 0.49% chance of exploitation in the next 30 days, higher than 41.8% of scored vulnerabilities.
Not severe (CVSS 8.8, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Timeline
- 10-07-2026PublishedVulnerability first disclosed.
- 10-07-2026Last modifiedVulnerability information updated.
Description
MaxKB is an open-source AI assistant for enterprise. Prior to 2.10.0-lts, MaxKB tool import functionality in apps/tools/serializers/tool.py and MCP referencing mode in apps/application/chat_pipeline/step/chat_step/impl/base_chat_step.py do not consistently validate MCP transport type, allowing an authenticated user to import a .tool file containing stdio transport with malicious commands and trigger the configuration through an AI Chat node so MultiServerMCPClient executes arbitrary system commands. This issue is fixed in version 2.10.0-lts.
CVSS metrics
2 scores · 2 sources · 1 version- NVDNIST8.8HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS trend
Probability
0.49%
Chance of exploitation in the next 30 days
Percentile
42%
Versus all other CVEs
30-day change
Decrease -0.06 pp
From 0.55% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, low-privilege account, no user interaction (CVSS vector). Other conditions: not stated in public data.
1panel-dev1 product
- maxkb< 2.10.0-lts
1 vendor · 1 product
References
2 links- github.com/1Panel-dev/MaxKB/security/advisories/GHSA-4pr3-9xhm-98x5X Refsource CONFIRM
- github.com/1Panel-dev/MaxKB/releases/tag/v2.10.0-ltsX Refsource MISC