CVE-2026-84292: fast-uri vulnerable to authority injection via an unvalidated port in serialize
Vulnerability summary
CVE-2026-84292 is a high (CVSS 7.5) Improper Encoding or Escaping of Output vulnerability in fast-uri. EPSS estimates a 0.24% chance of exploitation in the next 30 days, higher than 15% of scored vulnerabilities.
Severe, CVSS 7.5 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 0% (FIRST, 03-11-2026)
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 5Timeline
- 02-09-2026PublishedVulnerability first disclosed.
- 03-09-2026Last modifiedVulnerability information updated.
Description
fast-uri serializes the port component of a URI without validating it. When recomposing the authority, the userinfo and host components are escaped but the port is concatenated verbatim, so a port value that is not a sequence of digits can inject authority delimiters, demoting the intended host to userinfo and pointing the authority at an attacker-controlled host. Both fast-uri and Node's URL read the result back as the attacker's host with no error, so re-validating the built URI does not catch it. This affects applications that build URIs from parts and assign untrusted data to the port component through the serialize, normalize, or equal functions in their object forms. The issue affects fast-uri versions before 2.4.6, from 3.0.0 before 3.1.7, and from 4.0.0 before 4.1.4. It is fixed in 2.4.6, 3.1.7, and 4.1.4, where recomposeAuthority rejects any port that is not a digit sequence per RFC 3986.
CVSS metrics
7 scores · 7 sources · 1 version- OSV · UbuntuEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- OSV · DebianEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- OSV · WolfiEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- OSV · NpmEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- OSV · ChainguardEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- NVDNIST7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS trend
Probability
0.24%
Chance of exploitation in the next 30 days
Percentile
15%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.24% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Chainguard47 products
- airflow-2All versions (No fix recorded)
- airflow-core-2All versions (No fix recorded)
- commercial-gitlab-rails-ee-19.1< 19.1.7-r3
- commercial-gitlab-rails-ee-19.2< 19.2.7-r1
- commercial-gitlab-rails-ee-19.3< 19.3.3-r1
Wolfi7 products
- jupyter-base-notebook< 7.6.3-r2
- opensearch-dashboards-3< 3.8.0-r6
- prism< 5.16.0-r11
- renovate< 44.119.1-r0 | < 44.118.2-r0
- serve< 14.2.6-r7
Debian1 product
- node-ajvAll versions (No fix recorded) | < 8.20.0~ds+~cs7.1.5-1
Fast-uri1 product
- fast-uri< 2.4.6 | ≥ 3.0.0, < 3.1.7 | ≥ 4.0.0, < 4.1.4
Npm1 product
- fast-uri< 2.4.6 | ≥ 3.0.0, < 3.1.7 | ≥ 4.0.0, < 4.1.4
Openjsf1 product
- fast-uri< 2.4.6 | ≥ 3.0.0, < 3.1.7 | ≥ 4.0.0, < 4.1.4
Ubuntu1 product
- node-ajvAll versions (No fix recorded)
7 vendors · 59 products
References
12 links- github.com/fastify/fast-uri/security/advisories/GHSA-qw65-cvwx-89v3REPORTAdvisoryWEBMitigationVendor Advisory
- github.com/fastify/fast-uriPACKAGE