7.5

CVE-2026-84394: fast-uri vulnerable to host confusion via an unclosed bracket in the URI authority

Analyzed
AliasesUBUNTU-CVE-2026-84394DEBIAN-CVE-2026-84394CGA-253r-6jvj-8p93
Published 02-09-2026Last modified 03-09-2026

Vulnerability summary

CVE-2026-84394 is a high (CVSS 7.5) Interpretation Conflict vulnerability in fast-uri. EPSS estimates a 0.38% chance of exploitation in the next 30 days, higher than 32% of scored vulnerabilities.

Priority
Prioritisesevere

Severe, CVSS 7.5 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 0% (FIRST, 03-11-2026)

Source freshness unavailable

How is this decided?
CVSS score
7.5/10
010
High · v3.1 (CVE.org)
EPSS score
0.38%
0%100%
Low · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 4

Timeline

  1. 02-09-2026
    PublishedVulnerability first disclosed.
  2. 03-09-2026
    Last modifiedVulnerability information updated.

Description

fast-uri accepts a host that contains an unbalanced or misplaced authority bracket without reporting an error. A host that starts with an opening bracket but does not end with a closing bracket is neither validated as an IP literal nor canonicalized as a domain name, so parse() returns it as the host with error undefined, while Node's URL and the HTTP clients built on it resolve the same string to a different host. An application that reads the parsed host to make a host decision, such as an SSRF denylist, a redirect allowlist, or proxy routing, and then passes the original URL to an HTTP client evaluates its policy against a string that is not the host the request reaches. The same host is carried through normalize, equal, and resolve. This affects fast-uri versions 2.4.5, 3.1.6, and 4.1.3, and is fixed in 2.4.6, 3.1.7, and 4.1.4, where parse() reports a malformed host for any host that contains a bracket but is not a valid IPv6 literal.

CVSS metrics

7 scores · 7 sources · 1 version

EPSS trend

Probability

0.38%

Chance of exploitation in the next 30 days

Percentile

32%

Versus all other CVEs

30-day change

No change 0.00 pp

From 0.38% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Chainguard33 products
  • commercial-gitlab-rails-ee-19.1< 19.1.7-r3
  • commercial-gitlab-rails-ee-19.2< 19.2.7-r1
  • commercial-gitlab-rails-ee-19.3< 19.3.3-r1
  • commercial-gitlab-rails-ee-19.4< 19.4.1-r1
  • commercial-gitlab-rails-ee-fips-19.1All versions (No fix recorded) | < 19.1.9-r0
Wolfi6 products
  • opensearch-dashboards-3< 3.8.0-r6
  • prism< 5.16.0-r11
  • renovate< 44.119.1-r0 | < 44.118.2-r0
  • serve< 14.2.6-r7
  • vitess-24< 24.0.3-r10
Debian1 product
  • node-ajvAll versions (No fix recorded) | < 8.20.0~ds+~cs7.1.5-1
Fast-uri1 product
  • fast-uri≥ 2.4.5, < 2.4.6 | ≥ 3.1.6, < 3.1.7 | ≥ 4.1.3, < 4.1.4
Npm1 product
  • fast-uri≥ 2.4.5, < 2.4.6 | ≥ 3.1.6, < 3.1.7 | ≥ 4.1.3, < 4.1.4
Openjsf1 product
Ubuntu1 product
  • node-ajvAll versions (No fix recorded)

7 vendors · 44 products

References

13 links
Show all 13 references