Lodash vulnerabilities

10 vulnerabilities

Known vulnerabilities in Lodash products, newest first, with CVSS severity, EPSS, KEV listings and ransomware use, across 6 products.

Products

6
PrioritiseCVE-2026-4800lodash +90 morelodash vulnerable to Code Injection via `_.template` imports key namesImpact: The fix for CVE-2021-23337 (https://github.com/advisories/GHSA-35jh-r3h4-6jhm) added validation for the variable option in _.template but did not apply the same validation to options.imports key names. Both paths flow into the same Function() constructor sink. When an application passes untrusted input as options.imports key names, an attacker can inject default-parameter expressions that execute arbitrary code at template compilation time. Additionally, _.template uses assignInWith to merge imports, which enumerates inherited properties via for..in. If Object.prototype has been polluted by any other vector, the polluted keys are copied into the imports object and passed to Function(). Patches: Users should upgrade to version 4.18.0. Workarounds: Do not pass untrusted input as key names in options.imports. Only use developer-controlled, static key names.CVSS8.1HighEPSS2.81%PrioritiseCVE-2021-23337lodash +230 moreCommand InjectionThe fix for CVE-2021-23337 added validation for the variable option in _.template but did not apply the same validation to options.imports key names, and both paths flow into the same Function() constructor sink. When an application passes untrusted input as options.imports key names, an attacker can inject default-parameter expressions that execute arbitrary code at template compilation time. Additionally, _.template uses assignInWith to merge imports, which enumerates inherited properties via for..in, so if Object.prototype has been polluted by another vector the polluted keys are copied into the imports object and passed to Function(). The issue is fixed in 4.18.1 for lodash, lodash-es, lodash-amd, and lodash.template. As a workaround, do not pass untrusted input as key names in options.imports; use only developer-controlled, static key names.CVSS9.8CriticalEPSS21.33%RoutineCVE-2026-2950lodash +77 morelodash vulnerable to Prototype Pollution via array path bypass in `_.unset` and `_.omit`Impact: Lodash versions 4.17.23 and earlier are vulnerable to prototype pollution in the _.unset and _.omit functions. The fix for (CVE-2025-13465: https://github.com/lodash/lodash/security/advisories/GHSA-xxjr-mmjv-4gpg) only guards against string key members, so an attacker can bypass the check by passing array-wrapped path segments. This allows deletion of properties from built-in prototypes such as Object.prototype, Number.prototype, and String.prototype. The issue permits deletion of prototype properties but does not allow overwriting their original behavior. Patches: This issue is patched in 4.18.0. Workarounds: None. Upgrade to the patched version.CVSS6.5MediumEPSS0.34%RoutineCVE-2025-13465lodash +257 morePrototype Pollution Vulnerability in Lodash _.unset and _.omit functionsThe _.unset and _.omit functions in Lodash are vulnerable to prototype pollution. The fix for CVE-2025-13465 only guards against string key members, so an attacker can bypass the check by passing array-wrapped path segments. This allows deletion of properties from built-in prototypes such as Object.prototype, Number.prototype, and String.prototype. The issue permits deletion of prototype properties but does not allow overwriting their original behavior. The issue is patched from 4.18.0 to 4.18.1 depending on the package: lodash, lodash-es, and lodash-amd in 4.18.1, and the standalone lodash.unset and lodash.omit packages in 4.18.0.CVSS8.2HighEPSS1.82%RoutineCVE-2020-28500lodash +25 moreRegular Expression Denial of Service (ReDoS)Lodash versions prior to 4.17.21 are vulnerable to Regular Expression Denial of Service (ReDoS) via the toNumber, trim and trimEnd functions.CVSS5.3MediumEPSS7.34%PrioritiseCVE-2020-8203lodash +28 morelodash lodashPrototype pollution attack when using _.zipObjectDeep in lodash before 4.17.20.CVSS7.4HighEPSS5.21%PrioritiseCVE-2019-10744snyk · lodash +28 moresnyk lodashVersions of lodash lower than 4.17.12 are vulnerable to Prototype Pollution. The function defaultsDeep could be tricked into adding or modifying properties of Object.prototype using a constructor payload.CVSS9.1CriticalEPSS5.01%RoutineCVE-2019-1010266lodash +6 morelodash lodashlodash prior to 4.17.11 is affected by: CWE-400: Uncontrolled Resource Consumption. The impact is: Denial of service. The component is: Date handler. The attack vector is: Attacker provides very long strings, which the library attempts to match using a regular expression. The fixed version is: 4.17.11.CVSS6.5MediumEPSS3.04%RoutineCVE-2018-16487hackerone · lodash +5 morehackerone lodashA prototype pollution vulnerability was found in lodash <4.17.11 where the functions merge, mergeWith, and defaultsDeep can be tricked into adding or modifying properties of Object.prototype.CVSS6.8MediumEPSS1.49%RoutineCVE-2018-3721hackerone · lodash node module +7 morehackerone lodash node modulelodash node module before 4.17.5 suffers from a Modification of Assumed-Immutable Data (MAID) vulnerability via defaultsDeep, merge, and mergeWith functions, which allows a malicious user to modify the prototype of "Object" via __proto__, causing the addition or modification of an existing property that will exist on all objects.CVSS6.5MediumEPSS2.35%