7.8

CVE-2018-1000074: rubygems Deserialization of Untrusted Data

Modified
AliasesUBUNTU-CVE-2018-1000074USN-3621-2DEBIAN-CVE-2018-1000074
Published 13-03-2018Last modified 05-08-2024

Vulnerability summary

CVE-2018-1000074 is a high (CVSS 7.8) Deserialization of Untrusted Data vulnerability in rubygems. EPSS estimates a 2.88% chance of exploitation in the next 30 days, higher than 86.8% of scored vulnerabilities.

Priority
Routine

Not severe (CVSS 7.8, local access); no exploitation reported by the 5 checked sources

Source freshness unavailable

How is this decided?
CVSS score
7.8/10
010
High · v3.0 (NVD)
EPSS score
2.88%
0%100%
Low · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 18 · Related 5

Timeline

  1. 13-03-2018
    PublishedVulnerability first disclosed.
  2. 05-08-2024
    Last modifiedVulnerability information updated.

Description

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Deserialization of Untrusted Data vulnerability in owner command that can result in code execution. This attack appear to be exploitable via victim must run the `gem owner` command on a gem with a specially crafted YAML file. This vulnerability appears to have been fixed in 2.7.6.

CVSS metrics

6 scores · 5 sources · 2 versions

EPSS trend

Probability

2.88%

Chance of exploitation in the next 30 days

Percentile

87%

Versus all other CVEs

30-day change

No change 0.00 pp

From 2.88% on 05-10-2026

05-10-202604-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: local access, no authentication, user interaction (CVSS vector). Other conditions: not stated in public data.

Ubuntu4 products
  • jruby< 1.5.6-9+deb8u2build0.14.04.1~esm2 | All versions (No fix recorded)
  • ruby1.9.1< 1.9.3.484-2ubuntu1.12 | < 1.9.3.484-2ubuntu1.10
  • ruby2.0< 2.0.0.484-1ubuntu2.10 | < 2.0.0.484-1ubuntu2.8
  • ruby2.3< 2.3.1-2~16.04.7
Debian2 products
  • jruby< 1.5.6-5+deb7u2 | < 9.1.17.0-1
  • rubygems< 3.2.0~rc.1-1
RubyGems2 products
  • rubygems-update< 2.7.6
  • rubygems≤ 2.2.9 | ≤ 2.3.6 | ≤ 2.4.3 | ≤ 2.5.0
Org.jruby1 product
  • jruby-stdlib< 9.1.16.0

4 vendors · 9 products

References

31 links
Show all 31 references