CVE-2018-1000168: debian debian_linux Improper Input Validation
Vulnerability summary
CVE-2018-1000168 is a high (CVSS 7.5) Improper Input Validation vulnerability in debian debian_linux. EPSS estimates a 10.58% chance of exploitation in the next 30 days, higher than 95.7% of scored vulnerabilities.
Severe, CVSS 7.5 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 11% (FIRST, 04-11-2026)
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 6 · Related 4Timeline
- 08-05-2018PublishedVulnerability first disclosed.
- 09-06-2025Last modifiedVulnerability information updated.
Description
nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service. This attack appears to be exploitable via network client. This vulnerability appears to have been fixed in >= 1.31.1.
CVSS metrics
7 scores · 5 sources · 3 versions- NVDNIST7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · AlpineEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · UbuntuEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · DebianEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS trend
Probability
10.58%
Chance of exploitation in the next 30 days
Percentile
96%
Versus all other CVEs
30-day change
Decrease -0.07 pp
From 10.65% on 05-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root cause- CWE-20Improper Input ValidationThe product receives input or data, but it does not validate or incorrectly validates that the input has the properties that are required to process the data safely and correctly.
- CWE-476NULL Pointer DereferenceThe product dereferences a pointer that it expects to be valid but is NULL.
Affected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Debian2 products
- nghttp2< 1.31.1-1
- debian_linuxEOL9.0
Alpine1 product
- nodejs< 8.11.3-r0
Nghttp21 product
- nghttp2≥ 1.10.0, ≤ 1.31.0
Nodejs1 product
- node.js≥ 6.0.0, ≤ 6.8.1 | ≥ 8.4.0, ≤ 8.17.0 | ≥ 9.0.0, ≤ 9.11.2 | ≥ 10.0.0, < 10.4.1
Ubuntu1 product
- nghttp2< 1.30.0-1ubuntu1
5 vendors · 6 products
References
11 links- nodejs.org/en/blog/vulnerability/june-2018-security-releases/X Refsource CONFIRMRelease NotesThird Party Advisory
- lists.debian.org/debian-lts-announce/2021/10/msg00011.htmlMailing ListX Refsource MLISTThird Party Advisory