7.5

CVE-2022-0778: Infinite loop in BN_mod_sqrt() reachable when parsing certificates

Modified
AliasesALPINE-CVE-2022-0778MGASA-2022-0113SUSE-RU-2022:0861-1
Published 15-03-2022Last modified 14-10-2026

Vulnerability summary

CVE-2022-0778 is a high (CVSS 7.5) Loop with Unreachable Exit Condition vulnerability in debian debian_linux. EPSS estimates a 73.19% chance of exploitation in the next 30 days, higher than 99.4% of scored vulnerabilities.

Priority
Prioritisesevere

Severe, CVSS 7.5 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 73% (FIRST, 03-11-2026)

Source freshness unavailable

How is this decided?
CVSS score
7.5/10
010
High · v3.1 (CVE.org)
EPSS score
73.19%
0%100%
Critical · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 10 · Related 7

Timeline

  1. 15-03-2022
    PublishedVulnerability first disclosed.
  2. 14-10-2026
    Last modifiedVulnerability information updated.

Description

The BN_mod_sqrt() function, which computes a modular square root, contains a bug that can cause it to loop forever for non-prime moduli. Internally this function is used when parsing certificates that contain elliptic curve public keys in compressed form or explicit elliptic curve parameters with a base point encoded in compressed form. It is possible to trigger the infinite loop by crafting a certificate that has invalid explicit curve parameters. Since certificate parsing happens prior to verification of the certificate signature, any process that parses an externally supplied certificate may thus be subject to a denial of service attack. The infinite loop can also be reached when parsing crafted private keys as they can contain explicit elliptic curve parameters. Thus vulnerable situations include: - TLS clients consuming server certificates - TLS servers consuming client certificates - Hosting providers taking certificates or private keys from customers - Certificate authorities parsing certification requests from subscribers - Anything else which parses ASN.1 elliptic curve parameters Also any other applications that use the BN_mod_sqrt() where the attacker can control the parameter values are vulnerable to this DoS issue. In the OpenSSL 1.0.2 version the public key is not parsed during initial parsing of the certificate which makes it slightly harder to trigger the infinite loop. However any operation which requires the public key from the certificate will trigger the infinite loop. In particular the attacker can use a self-signed certificate to trigger the loop during verification of the certificate signature. This issue affects OpenSSL versions 1.0.2, 1.1.1 and 3.0. It was addressed in the releases of 1.1.1n and 3.0.2 on the 15th March 2022. Fixed in OpenSSL 3.0.2 (Affected 3.0.0,3.0.1). Fixed in OpenSSL 1.1.1n (Affected 1.1.1-1.1.1m). Fixed in OpenSSL 1.0.2zd (Affected 1.0.2-1.0.2zc).

CVSS metrics

10 scores · 9 sources · 2 versions

EPSS trend

Probability

73.19%

Chance of exploitation in the next 30 days

Percentile

99%

Versus all other CVEs

30-day change

No change 0.00 pp

From 73.19% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Suse111 products
  • compat-openssl098&distro=SUSE Linux Enterprise Module for Legacy 12< 0.9.8j-106.33.1
  • compat-openssl098&distro=SUSE Linux Enterprise Server for SAP Applications 12 SP3< 0.9.8j-106.33.1
  • compat-openssl098&distro=SUSE Linux Enterprise Server for SAP Applications 12 SP4< 0.9.8j-106.33.1
  • compat-openssl098&distro=SUSE Linux Enterprise Server for SAP Applications 12 SP5< 0.9.8j-106.33.1
  • glibc&distro=SUSE Linux Enterprise Micro 5.1< 2.31-150300.20.7
Redhat28 products
  • compat-openssl10< 1:1.0.2o-4.el8_6
  • compat-openssl10-debuginfo< 1:1.0.2o-4.el8_6
  • compat-openssl10-debugsource< 1:1.0.2o-4.el8_6
  • compat-openssl11< 1:1.1.1k-4.el9_0
  • compat-openssl11-debuginfo< 1:1.1.1k-4.el9_0
Alpine7 products
  • libressl< 3.3.6-r0 | < 3.4.3-r0
  • libretls< 3.3.3p1-r3 | < 3.3.4-r3 | < 3.5.1-r0
  • lighthouse< 2.2.0-r0
  • openjdk11< 11.0.15_p10-r0
  • openssl≥ 1.0.2, < 1.1.1n-r0 | ≥ 1.0.2, < 3.0.2-r0
Netapp7 products
Opensuse6 products
  • cargo-audit-advisory-db&distro=openSUSE Tumbleweed< 20220323-1.1
  • libressl&distro=openSUSE Tumbleweed< 3.4.3-1.1
  • openssl-1_0_0&distro=openSUSE Leap 15.3< 1.0.2p-3.49.1
  • openssl-1_1&distro=openSUSE Tumbleweed< 1.1.1n-1.1
  • openssl-3&distro=openSUSE Tumbleweed< 3.0.2-1.1
Ubuntu4 products
  • edk2All versions (No fix recorded) | < 2022.02-3ubuntu0.22.04.4
  • nodejs< 12.22.9~dfsg-1ubuntu3.1
  • openssl< 1.0.2g-1ubuntu4.fips.4.20.2 | All versions (No fix recorded) | < 1.1.1-1ubuntu2.fips.2.1~18.04.15 | < 1.1.1f-1ubuntu2.fips.12 | < 3.0.2-0ubuntu1 | < 1.1.1-1ubuntu2.1~18.04.15 | < 1.1.1f-1ubuntu2.12 | < 1.0.1f-1ubuntu2.27+esm5 | < 1.0.2g-1ubuntu4.20+esm2
  • openssl1.0< 1.0.2n-1ubuntu5.8
Debian3 products
  • openssl< 1.1.1n-1
  • openssl1.0< 1.0.2u-1~deb9u7
  • debian_linuxEOL9.0 | 10.0 | 11.0
Chainguard2 products
  • eco-dotnet-libssl-1.0All versions (No fix recorded)
  • ruby-3.1All versions (No fix recorded)
Crates.Io1 product
  • openssl-src< 111.18.0 | ≥ 300.0.0, < 300.0.5
Fedoraproject1 product
Mageia1 product
  • openssl< 1.1.1n-1.mga8
Mariadb1 product
  • mariadb≥ 10.2.0, < 10.2.42 | ≥ 10.3.0, < 10.3.33 | ≥ 10.4.0, < 10.4.23 | ≥ 10.5.0, < 10.5.14 | ≥ 10.6.0, < 10.6.6 | ≥ 10.7.0, < 10.7.2
Nodejs1 product
  • node.js≥ 12.0.0, ≤ 12.12.0 | ≥ 12.13.0, < 12.22.11 | > 14.0.0, ≤ 14.14.0 | ≥ 14.15.0, < 14.19.1 | > 16.0.0, ≤ 16.12.0 | ≥ 16.13.0, < 16.14.2 | > 17.0.0, < 17.7.2
Openssl1 product
  • opensslFixed in OpenSSL 3.0.2 (Affected 3.0.0,3.0.1) | Fixed in OpenSSL 1.1.1n (Affected 1.1.1-1.1.1m) | Fixed in OpenSSL 1.0.2zd (Affected 1.0.2-1.0.2zc) | ≥ 1.0.2, < 1.0.2zd | ≥ 1.1.0, < 1.1.1n | ≥ 3.0.0, < 3.0.2
Tenable1 product
  • nessus< 8.15.4 | ≥ 10.0.0, < 10.1.2
Wolfi1 product
  • ruby-3.1All versions (No fix recorded)

16 vendors · 176 products

References

112 links
Show all 100 references

Showing 100 of 112.