7.5

CVE-2022-29244: npm packing does not respect root-level ignore files in workspaces

Modified
AliasesUBUNTU-CVE-2022-29244GHSA-hj9c-8jmm-8c52openSUSE-SU-2024:12280-1
Published 13-06-2022Last modified 23-04-2025

Vulnerability summary

CVE-2022-29244 is a high (CVSS 7.5) vulnerability in netapp ontap_select_deploy_administration_utility. EPSS estimates a 4.00% chance of exploitation in the next 30 days, higher than 90.5% of scored vulnerabilities.

Priority
Prioritisesevere

Severe, CVSS 7.5 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 4% (FIRST, 03-11-2026)

Source freshness unavailable

How is this decided?
CVSS score
7.5/10
010
High · v3.1 (CVE.org)
EPSS score
4.00%
0%100%
Low · +0.09 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 4 · Related 3

Timeline

  1. 13-06-2022
    PublishedVulnerability first disclosed.
  2. 23-04-2025
    Last modifiedVulnerability information updated.

Description

npm pack ignores root-level .gitignore and .npmignore file exclusion directives when run in a workspace or with a workspace flag (ie. `--workspaces`, `--workspace=<name>`). Anyone who has run `npm pack` or `npm publish` inside a workspace, as of v7.9.0 and v7.13.0 respectively, may be affected and have published files into the npm registry they did not intend to include. Users should upgrade to the latest, patched version of npm v8.11.0, run: npm i -g npm@latest . Node.js versions v16.15.1, v17.19.1, and v18.3.0 include the patched v8.11.0 version of npm.

CVSS metrics

5 scores · 4 sources · 2 versions

EPSS trend

Probability

4.00%

Chance of exploitation in the next 30 days

Percentile

91%

Versus all other CVEs

30-day change

Increase +0.09 pp

From 3.91% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Netapp1 product
Npm1 product
  • npm≥ 7.9.0, < 8.11.0 | ≥ 7.9.0, < 7.9.0* | ≥ 8.11.0, < 8.11.0
Npmjs1 product
  • npm≥ 7.9.0, < 8.11.0
Opensuse1 product
  • nodejs16&distro=openSUSE Tumbleweed< 16.17.0-1.1
Ubuntu1 product
  • npmAll versions (No fix recorded)

5 vendors · 5 products

References

16 links
Show all 16 references