CVE-2026-44849: Portainer: Endpoint security bypass via Swarm service create/update
Vulnerability summary
CVE-2026-44849 is a critical (CVSS 9.4) Missing Authorization vulnerability in portainer. EPSS estimates a 0.43% chance of exploitation in the next 30 days, higher than 36.8% of scored vulnerabilities. 1 public exploit is recorded.
Public exploit (GitHub, Date unknown)
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 1 · Related 1Timeline
- 28-05-2026PublishedVulnerability first disclosed.
- 29-05-2026Last modifiedVulnerability information updated.
Description
Portainer Community Edition is a lightweight service delivery platform for containerized applications that can be used to manage Docker, Swarm, Kubernetes and ACI environments. From 2.33.0 to before 2.33.8, 2.39.2, and 2.41.0, Portainer enforces seven EndpointSecuritySettings restrictions that administrators configure to restrict the container configurations non-admin users can launch: privileged mode, host PID namespace, device mapping, capabilities, sysctls, security-opt (Seccomp / AppArmor), and bind mounts. These restrictions are enforced on the standard container creation path, but several of them are not applied on the Docker Swarm service API. This vulnerability is fixed in 2.33.8, 2.39.2, and 2.41.0.
CVSS metrics
5 scores · 3 sources · 2 versions- OSV · GoEcosystem advisory · calculated9.4CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
- NVDNIST9.4CriticalCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- NVDNIST8.8HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS trend
Probability
0.43%
Chance of exploitation in the next 30 days
Percentile
37%
Versus all other CVEs
30-day change
Decrease -0.02 pp
From 0.45% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
1 foundPortainer
Maturity: poc
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, low-privilege account, no user interaction (CVSS vector). Other conditions: not stated in public data.
Github.com/portainer1 product
- portainer≥ 2.33.0, < 2.33.8 | ≥ 2.39.0, < 2.39.2 | ≥ 2.40.0, < 2.41.0 | All versions (No fix recorded)
Portainer1 product
- portainer≥ 2.39.0, < 2.39.2 | ≥ 2.40.0, < 2.41.0 | ≥ 2.33.0, < 2.33.8 | ≥ 2.34.0, < 2.39.1 | 2.40.0
2 vendors · 2 products
References
6 links- github.com/portainer/portainer/security/advisories/GHSA-5fxq-qcf3-244wX Refsource CONFIRMWEBAdvisoryExploitThird Party Advisory