CVE-2026-44850: Portainer: Bind-mount restriction bypass via HostConfig.Mounts
Vulnerability summary
CVE-2026-44850 is a high (CVSS 8.5) Incorrect Authorization vulnerability in portainer. EPSS estimates a 0.23% chance of exploitation in the next 30 days, higher than 14.3% of scored vulnerabilities. 1 public exploit is recorded.
Public exploit (GitHub, Date unknown)
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 1 · Related 1Timeline
- 28-05-2026PublishedVulnerability first disclosed.
- 29-05-2026Last modifiedVulnerability information updated.
Description
Portainer Community Edition is a lightweight service delivery platform for containerized applications that can be used to manage Docker, Swarm, Kubernetes and ACI environments. From 2.33.0 to before 2.33.8, 2.39.2, and 2.41.0, Portainer offers an environment-level Disable bind mounts for non-administrators security setting that blocks regular users from binding host paths into containers they create through the Portainer-mediated Docker API. The check that enforces this setting only inspected the legacy HostConfig.Binds array on the container-create proxy and never looked at the equivalent HostConfig.Mounts array. Any authenticated user with rights to create containers on a Docker environment where the restriction is enabled could submit a bind-typed entry under HostConfig.Mounts and mount any host path into their container. This vulnerability is fixed in 2.33.8, 2.39.2, and 2.41.0.
CVSS metrics
3 scores · 3 sources · 1 version- OSV · GoEcosystem advisory · calculated8.5HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
- NVDNIST8.5HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
EPSS trend
Probability
0.23%
Chance of exploitation in the next 30 days
Percentile
14%
Versus all other CVEs
30-day change
Decrease -0.07 pp
From 0.30% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
1 foundPortainer
Maturity: poc
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, low-privilege account, no user interaction (CVSS vector). Other conditions: not stated in public data.
Github.com/portainer1 product
- portainer≥ 2.33.0, < 2.33.8 | ≥ 2.39.0, < 2.39.2 | ≥ 2.40.0, < 2.41.0 | All versions (No fix recorded)
Portainer1 product
- portainer≥ 2.39.0, < 2.39.2 | ≥ 2.40.0, < 2.41.0 | ≥ 2.33.0, < 2.33.8 | ≥ 2.34.0, < 2.39.1 | 2.40.0
2 vendors · 2 products
References
6 links- github.com/portainer/portainer/security/advisories/GHSA-7fw3-x4r2-g7wcX Refsource CONFIRMWEBAdvisoryExploitThird Party Advisory