8.3

CVE-2026-84319: Nginx UI: MCP configuration tools bypass restricted directive validation and allow secondary authenticated users to execute NJS in Nginx worker context

Deferred
AliasesGHSA-5r62-gj48-897xGO-2026-6774
Published 12-10-2026Last modified 13-10-2026

Vulnerability summary

CVE-2026-84319 is a high (CVSS 8.3) Protection Mechanism Failure vulnerability in 0xjacky nginx-ui. EPSS estimates a 0.28% chance of exploitation in the next 30 days, higher than 20.5% of scored vulnerabilities.

Priority
Routine

Not severe (CVSS 8.3, network access); no exploitation reported by the 5 checked sources

Source freshness unavailable

How is this decided?
CVSS score
8.3/10
010
High · v3.1 (NVD)
EPSS score
0.28%
0%100%
Low · Change unavailable
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Timeline

  1. 12-10-2026
    PublishedVulnerability first disclosed.
  2. 13-10-2026
    Last modifiedVulnerability information updated.

Description

Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the regular HTTP configuration API rejects restricted Nginx directives such as load_module, js_import, and js_content. However, the MCP configuration interface allows a secondary authenticated user to write and apply equivalent restricted configuration content. This allows the user to load ngx_http_js_module.so, import attacker-controlled JavaScript, reload Nginx, and execute NJS in the Nginx worker context. This issue is fixed in version 2.4.1.

CVSS metrics

3 scores · 3 sources · 1 version

EPSS trend

Probability

0.28%

Chance of exploitation in the next 30 days

Percentile

21%

Versus all other CVEs

30-day change

Change unavailable

Change unavailable

13-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, low-privilege account, no user interaction (CVSS vector). Other conditions: not stated in public data.

0xjacky1 product
Github.com/0xJacky1 product
  • Nginx-UI< 1.9.10-0.20260703131214-23d1934099b0

2 vendors · 2 products

References

5 links