CVE-2026-84360: Nginx UI: OTP secure-session step-up can be bypassed via MCP configuration tools
Vulnerability summary
CVE-2026-84360 is a high (CVSS 8.1) vulnerability in 0xjacky nginx-ui. EPSS estimates a 0.42% chance of exploitation in the next 30 days, higher than 36.3% of scored vulnerabilities.
Not severe (CVSS 8.1, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Timeline
- 12-10-2026PublishedVulnerability first disclosed.
- 13-10-2026Last modifiedVulnerability information updated.
Description
Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the HTTP configuration mutation routes require RequireSecureSession, but /mcp and /mcp_message require only ordinary authentication before exposing nginx_config_add and nginx_config_modify. An OTP-enabled user with a normal JWT but no valid X-Secure-Session-ID can therefore create or modify Nginx configuration and trigger reload behavior through MCP, bypassing the intended step-up control. This issue is fixed in version 2.4.1.
CVSS metrics
3 scores · 3 sources · 1 version- CVE.orgCNA8.1HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
- OSV · GoEcosystem advisory · calculated8.1HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
EPSS trend
Probability
0.42%
Chance of exploitation in the next 30 days
Percentile
36%
Versus all other CVEs
30-day change
Change unavailable
Change unavailable
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, low-privilege account, no user interaction (CVSS vector). Other conditions: not stated in public data.
0xjacky1 product
- nginx-ui< 2.4.1
Github.com/0xJacky1 product
- Nginx-UI< 1.9.10-0.20260703131214-23d1934099b0
2 vendors · 2 products
References
5 links- github.com/0xJacky/nginx-uiPACKAGE