CVE-2026-94609: authentik: Privilege Escalation to Superuser via Group Hierarchy
Vulnerability summary
CVE-2026-94609 is a high (CVSS 8.8) Improper Privilege Management vulnerability in goauthentik authentik. EPSS estimates a 0.51% chance of exploitation in the next 30 days, higher than 43.8% of scored vulnerabilities.
Not severe (CVSS 8.8, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Timeline
- 24-09-2026PublishedVulnerability first disclosed.
- 28-09-2026Last modifiedVulnerability information updated.
Description
authentik is an open-source identity provider. Prior to 2026.2.7, 2026.5.7, and 2026.8.2, an account with delegated permission to manage a group, group membership, or a user can grant superuser status to an account or assign an existing role to a group without holding the permissions that gate those privileges. Group hierarchy checks do not consistently account for superuser status inherited from ancestor groups, and role assignment to a group lacks the required authorization check. Only deployments that delegate these management capabilities to accounts that are not full administrators are affected. This issue is fixed in versions 2026.2.7, 2026.5.7, and 2026.8.2.
CVSS metrics
2 scores · 2 sources · 1 version- NVDNIST8.8HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS trend
Probability
0.51%
Chance of exploitation in the next 30 days
Percentile
44%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.51% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root cause- CWE-269Improper Privilege ManagementThe product does not properly assign, modify, track, or check privileges for an actor, creating an unintended sphere of control for that actor.
- CWE-863Incorrect AuthorizationThe product performs an authorization check when an actor attempts to access a resource or perform an action, but it does not correctly perform the check.
Affected systems
Known conditions: network-reachable, low-privilege account, no user interaction (CVSS vector). Other conditions: not stated in public data.
Goauthentik1 product
- authentik< 2026.2.7 | ≥ 2026.5.0, < 2026.5.7 | ≥ 2026.8.0, < 2026.8.2
1 vendor · 1 product
References
15 links- github.com/goauthentik/authentik/security/advisories/GHSA-h6c5-mpvq-j4jcX Refsource CONFIRM
- github.com/goauthentik/authentik/pull/25956X Refsource MISC
- github.com/goauthentik/authentik/pull/25961X Refsource MISC
- github.com/goauthentik/authentik/pull/25966X Refsource MISC
- github.com/goauthentik/authentik/pull/25971X Refsource MISC
- docs.goauthentik.io/releases/2026.2X Refsource MISC
Show all 15 references
- docs.goauthentik.io/releases/2026.5X Refsource MISC
- docs.goauthentik.io/releases/2026.8X Refsource MISC
- github.com/goauthentik/authentik/releases/tag/version/2026.2.7X Refsource MISC
- github.com/goauthentik/authentik/releases/tag/version/2026.5.7X Refsource MISC
- github.com/goauthentik/authentik/releases/tag/version/2026.8.2X Refsource MISC