CVE-2026-94611: authentik: Stored credentials are readable with view permission alone
Vulnerability summary
CVE-2026-94611 is a high (CVSS 8.1) vulnerability in goauthentik authentik. EPSS estimates a 0.33% chance of exploitation in the next 30 days, higher than 26.7% of scored vulnerabilities.
Not severe (CVSS 8.1, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Timeline
- 24-09-2026PublishedVulnerability first disclosed.
- 24-09-2026Last modifiedVulnerability information updated.
Description
authentik is an open-source identity provider. Prior to 2026.2.7, 2026.5.7, and 2026.8.2, authentik API serializers return stored credentials when an account has view permission on an affected configuration, even when that account is not authorized to change the configuration or read its secrets. Affected configurations include one-time code delivery by mail or SMS, outbound provisioning targets, device trust integrations, identity sources, the Kubernetes outpost integration, applications using a client or shared secret, and applications using a proxy provider. Deployments are affected when view permission is granted to accounts that are not intended to read these credentials; deployments where every viewer is permitted to read them are not affected. This issue is fixed in versions 2026.2.7, 2026.5.7, and 2026.8.2.
CVSS metrics
2 scores · 2 sources · 1 version- NVDNIST8.1HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS trend
Probability
0.33%
Chance of exploitation in the next 30 days
Percentile
27%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.33% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root cause- CWE-200Exposure of Sensitive Information to an Unauthorized ActorThe product exposes sensitive information to an actor that is not explicitly authorized to have access to that information.
- CWE-522Insufficiently Protected CredentialsThe product transmits or stores authentication credentials, but it uses an insecure method that is susceptible to unauthorized interception and/or retrieval.
Affected systems
Known conditions: network-reachable, low-privilege account, no user interaction (CVSS vector). Other conditions: not stated in public data.
Goauthentik1 product
- authentik< 2026.2.7 | ≥ 2026.5.0, < 2026.5.7 | ≥ 2026.8.0, < 2026.8.2
1 vendor · 1 product
References
15 links- github.com/goauthentik/authentik/security/advisories/GHSA-m9h4-7j9c-55x9X Refsource CONFIRM
- github.com/goauthentik/authentik/pull/25955X Refsource MISC
- github.com/goauthentik/authentik/pull/25960X Refsource MISC
- github.com/goauthentik/authentik/pull/25965X Refsource MISC
- github.com/goauthentik/authentik/pull/25970X Refsource MISC
- docs.goauthentik.io/releases/2026.2X Refsource MISC
Show all 15 references
- docs.goauthentik.io/releases/2026.5X Refsource MISC
- docs.goauthentik.io/releases/2026.8X Refsource MISC
- github.com/goauthentik/authentik/releases/tag/version/2026.2.7X Refsource MISC
- github.com/goauthentik/authentik/releases/tag/version/2026.5.7X Refsource MISC
- github.com/goauthentik/authentik/releases/tag/version/2026.8.2X Refsource MISC