CVE-2026-94612: authentik: Authentication bypass via assertion confusion in SAML sources
Vulnerability summary
CVE-2026-94612 is a high (CVSS 7.4) Improper Authentication vulnerability in goauthentik authentik. EPSS estimates a 0.27% chance of exploitation in the next 30 days, higher than 18.9% of scored vulnerabilities.
Severe, CVSS 7.4 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 0% (FIRST, 03-11-2026)
Source freshness unavailable
How is this decided?Timeline
- 24-09-2026PublishedVulnerability first disclosed.
- 24-09-2026Last modifiedVulnerability information updated.
Description
authentik is an open-source identity provider. Prior to 2026.2.7, 2026.5.7, and 2026.8.2, an authentik SAML Source verifies an assertion's signature and validity period but does not ensure that the identity provider issued the assertion for that Source or in response to a login request from that Source. The SAML Source also does not record already accepted assertions, allowing replay. An unauthenticated actor who possesses such a valid assertion can use an assertion intended for another service provider or reuse an earlier assertion to authenticate as the user named by the assertion. Only SAML Sources are affected; SAML Providers and other Source types are not affected. This issue is fixed in versions 2026.2.7, 2026.5.7, and 2026.8.2.
CVSS metrics
2 scores · 2 sources · 1 version- NVDNIST7.4HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS trend
Probability
0.27%
Chance of exploitation in the next 30 days
Percentile
19%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.27% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root cause- CWE-287Improper AuthenticationWhen an actor claims to have a given identity, the product does not prove or insufficiently proves that the claim is correct.
- CWE-345Insufficient Verification of Data AuthenticityThe product does not sufficiently verify the origin or authenticity of data, in a way that causes it to accept invalid data.
Affected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Goauthentik1 product
- authentik< 2026.2.7 | ≥ 2026.5.0, < 2026.5.7 | ≥ 2026.8.0, < 2026.8.2
1 vendor · 1 product
References
15 links- github.com/goauthentik/authentik/security/advisories/GHSA-cqj8-fxxf-9pg7X Refsource CONFIRM
- github.com/goauthentik/authentik/pull/25957X Refsource MISC
- github.com/goauthentik/authentik/pull/25962X Refsource MISC
- github.com/goauthentik/authentik/pull/25967X Refsource MISC
- github.com/goauthentik/authentik/pull/25972X Refsource MISC
- docs.goauthentik.io/releases/2026.2X Refsource MISC
Show all 15 references
- docs.goauthentik.io/releases/2026.5X Refsource MISC
- docs.goauthentik.io/releases/2026.8X Refsource MISC
- github.com/goauthentik/authentik/releases/tag/version/2026.2.7X Refsource MISC
- github.com/goauthentik/authentik/releases/tag/version/2026.5.7X Refsource MISC
- github.com/goauthentik/authentik/releases/tag/version/2026.8.2X Refsource MISC