8.8

CVE-2024-22198: Authenticated (user role) arbitrary command execution by modifying `start_cmd` setting (GHSL-2023-268)

Modified
AliasesGHSA-8r25-68wm-jw35GO-2024-2462
Published 11-01-2024Last modified 01-08-2024

Vulnerability summary

CVE-2024-22198 is a high (CVSS 8.8) vulnerability in 0xjacky nginx-ui. EPSS estimates a 4.06% chance of exploitation in the next 30 days, higher than 90.6% of scored vulnerabilities. 1 public exploit is recorded.

Priority
Prioritisepublic exploit

Public exploit (GitHub, Date unknown)

Source freshness unavailable

How is this decided?
CVSS score
8.8/10
010
High · v3.1 (NVD)
EPSS score
4.06%
0%100%
Low · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits1github

Timeline

  1. 11-01-2024
    PublishedVulnerability first disclosed.
  2. 01-08-2024
    Last modifiedVulnerability information updated.

Description

Nginx-UI is a web interface to manage Nginx configurations. It is vulnerable to arbitrary command execution by abusing the configuration settings. The `Home > Preference` page exposes a list of system settings such as `Run Mode`, `Jwt Secret`, `Node Secret` and `Terminal Start Command`. While the UI doesn't allow users to modify the `Terminal Start Command` setting, it is possible to do so by sending a request to the API. This issue may lead to authenticated remote code execution, privilege escalation, and information disclosure. This vulnerability has been patched in version 2.0.0.beta.9.

CVSS metrics

3 scores · 3 sources · 1 version

EPSS trend

Probability

4.06%

Chance of exploitation in the next 30 days

Percentile

91%

Versus all other CVEs

30-day change

No change 0.00 pp

From 4.06% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

1 found
  • githubUnverified

    Nginx Ui

    Maturity: poc

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, low-privilege account, no user interaction (CVSS vector). Other conditions: not stated in public data.

0xjacky1 product
Github.com/0xJacky1 product
  • Nginx-UI< 1.9.10-0.20231219184941-827e76c46e63
Nginxui1 product
  • nginx_ui< 2.0.0 | 2.0.0:beta1 | 2.0.0:beta2 | 2.0.0:beta3 | 2.0.0:beta4 | 2.0.0:beta4_patch | 2.0.0:beta5 | 2.0.0:beta5_patch | 2.0.0:beta6 | 2.0.0:beta6_patch | 2.0.0:beta6_patch2 | 2.0.0:beta7 | 2.0.0:beta8 | 2.0.0:beta8_patch

3 vendors · 3 products

References

11 links
Show all 11 references