CVE-2026-107813: Nginx UI: Incomplete fix of CVE-2026-84315 - the api/cluster router was not - wrapped in RequireSecureSession, so those sensitive mutations run without OTP step-up
Vulnerability summary
CVE-2026-107813 is a high (CVSS 8.8) Missing Authorization vulnerability in 0xjacky nginx-ui. EPSS estimates a 0.30% chance of exploitation in the next 30 days, higher than 23.3% of scored vulnerabilities.
Not severe (CVSS 8.8, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Timeline
- 09-10-2026PublishedVulnerability first disclosed.
- 09-10-2026Last modifiedVulnerability information updated.
Description
Nginx UI is a web user interface for the Nginx web server. From 2.0.0 until 2.5.0, the api/cluster router exposes node and namespace mutation operations and cluster-wide Nginx reload or restart operations with AuthRequired but without RequireSecureSession. An authenticated OTP-enabled user possessing a stolen or persisted JWT can therefore perform node CRUD, read or replace node credentials, change namespaces, and invoke nodes/reload_nginx or nodes/restart_nginx without a fresh second-factor step-up. This issue is an incomplete fix for CVE-2026-84315 and is fixed in version 2.5.0.
CVSS metrics
3 scores · 3 sources · 1 version- OSV · GoEcosystem advisory · calculated8.8HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- NVDNIST8.8HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS trend
Probability
0.30%
Chance of exploitation in the next 30 days
Percentile
23%
Versus all other CVEs
30-day change
Change unavailable
Change unavailable
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, low-privilege account, no user interaction (CVSS vector). Other conditions: not stated in public data.
0xjacky1 product
- nginx-ui≥ 2.0.0, < 2.5.0
Github.com/0xJacky1 product
- Nginx-UI≥ 1.9.10-0.20250517140552-daee3ac7ade1, < 1.9.10-0.20260728074433-a3999bd78a3b
Nginxui1 product
- nginx_ui≥ 2.0.0, < 2.5.0
3 vendors · 3 products
References
4 links- github.com/0xJacky/nginx-ui/security/advisories/GHSA-h246-wpgf-vmq5X Refsource CONFIRMWEBAdvisoryVendor Advisory
- github.com/0xJacky/nginx-uiPACKAGE